aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmonobut
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xmonobut
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xmonobut')
-rw-r--r--recipes/xmonobut/xmonobut.desktop7
-rw-r--r--recipes/xmonobut/xmonobut_0.4.1.bb17
-rw-r--r--recipes/xmonobut/xmonobut_0.4.bb17
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/xmonobut/xmonobut.desktop b/recipes/xmonobut/xmonobut.desktop
new file mode 100644
index 0000000000..6e855cede4
--- /dev/null
+++ b/recipes/xmonobut/xmonobut.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=xmonobut
+Comment=A tool to modify mouse button behaviour.
+Exec=xmonobut
+Type=PanelApp
+Icon=xmonobut.xpm
+Categories=Panel;Utility
diff --git a/recipes/xmonobut/xmonobut_0.4.1.bb b/recipes/xmonobut/xmonobut_0.4.1.bb
new file mode 100644
index 0000000000..813a390c7c
--- /dev/null
+++ b/recipes/xmonobut/xmonobut_0.4.1.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+PR = "r1"
+DESCRIPTION = "utility to allow middle and right clicking with a stylus"
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxext libxpm libmatchbox"
+SRC_URI = "http://www.handhelds.org/~philippe/sources/xmonobut-${PV}.tar.gz \
+ file://xmonobut.desktop"
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 xmonobut ${D}${bindir}/xmonobut
+ install -m 0644 xmonobut.xpm ${D}${datadir}/pixmaps/xmonobut.xpm
+ install -m 0644 ${WORKDIR}/xmonobut.desktop ${D}${datadir}/applications/xmonobut.desktop
+}
diff --git a/recipes/xmonobut/xmonobut_0.4.bb b/recipes/xmonobut/xmonobut_0.4.bb
new file mode 100644
index 0000000000..97ebcbd84c
--- /dev/null
+++ b/recipes/xmonobut/xmonobut_0.4.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+PR = "r1"
+DESCRIPTION = "utility to allow middle and right clicking with a stylus"
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxext libxpm"
+SRC_URI = "http://www.handhelds.org/~mallum/downloadables/xmonobut/xmonobut-${PV}.tar.gz \
+ file://xmonobut.desktop"
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 xmonobut ${D}${bindir}/xmonobut
+ install -m 0644 xmonobut.xpm ${D}${datadir}/pixmaps/xmonobut.xpm
+ install -m 0644 ${WORKDIR}/xmonobut.desktop ${D}${datadir}/applications/xmonobut.desktop
+}