aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-app
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-13 09:28:04 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-13 09:28:04 +0000
commit509fe8bba28753b7dff021b7216cb65cb9e3d180 (patch)
treeab7c93c11328fcef9e2dad0ce5297ec08bbec9fa /recipes/xorg-app
parent14a73529b5d431f148c441e6a32c7ad52713db19 (diff)
downloadopenembedded-509fe8bba28753b7dff021b7216cb65cb9e3d180.tar.gz
xterm_207.bb : fix problem on "SELinux" F11 based builds
xterm_251.bb : fix problem on "SELinux" F11 based builds This was not really F11 or SELinux problem, installer was checking for the existance of /usr/bin/X11/xterm and trying to read the permissions for that and replicate them into the OE build. A simple --disable-setuid prevents this script being called and the bogus check on host tools from occuring.
Diffstat (limited to 'recipes/xorg-app')
-rw-r--r--recipes/xorg-app/xterm_207.bb10
-rw-r--r--recipes/xorg-app/xterm_243.bb28
-rw-r--r--recipes/xorg-app/xterm_251.bb10
3 files changed, 10 insertions, 38 deletions
diff --git a/recipes/xorg-app/xterm_207.bb b/recipes/xorg-app/xterm_207.bb
index f8ed913117..0f31f41de3 100644
--- a/recipes/xorg-app/xterm_207.bb
+++ b/recipes/xorg-app/xterm_207.bb
@@ -10,12 +10,12 @@ inherit autotools pkgconfig
FILES_${PN} += " /usr/lib/X11"
-#EXTRA_OERECONF = " -I${S}/xterm.m4"
-EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config --disable-imake"
+EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
+ FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
+ --disable-imake \
+ --disable-setuid"
-#do_configure_prepend () {
-# mv ${S}/aclocal.m4 ${S}/xterm.m4
-#}
do_configure() {
sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
diff --git a/recipes/xorg-app/xterm_243.bb b/recipes/xorg-app/xterm_243.bb
deleted file mode 100644
index 5764da39fe..0000000000
--- a/recipes/xorg-app/xterm_243.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "xterm is the standard terminal emulator for the X Window System."
-SECTION = "x11/applications"
-LICENSE = "MIT-X"
-
-DEPENDS = "libxaw xproto virtual/libx11 xextproto xext xau libxpm ncurses"
-
-SRC_URI = "ftp://invisible-island.net/xterm/${PN}-${PV}.tgz"
-
-inherit autotools pkgconfig
-
-FILES_${PN} += " /usr/lib/X11"
-
-#EXTRA_OERECONF = " -I${S}/xterm.m4"
-EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config --disable-imake"
-
-#do_configure_prepend () {
-# mv ${S}/aclocal.m4 ${S}/xterm.m4
-#}
-do_configure() {
-
- sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
-
- oe_runconf
-}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/xorg-app/xterm_251.bb b/recipes/xorg-app/xterm_251.bb
index 5764da39fe..004679e3b7 100644
--- a/recipes/xorg-app/xterm_251.bb
+++ b/recipes/xorg-app/xterm_251.bb
@@ -10,12 +10,12 @@ inherit autotools pkgconfig
FILES_${PN} += " /usr/lib/X11"
-#EXTRA_OERECONF = " -I${S}/xterm.m4"
-EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config --disable-imake"
+EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
+ FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
+ --disable-imake \
+ --disable-setuid"
-#do_configure_prepend () {
-# mv ${S}/aclocal.m4 ${S}/xterm.m4
-#}
do_configure() {
sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure