aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-app
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-22 12:32:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-22 19:51:03 +0200
commit5cb3bdc4a3151c4ee9f7822e75ac9bf6d70395a4 (patch)
tree2e795749e30328e8bfeda4ccc882a18e9bdb3e53 /recipes/xorg-app
parent034c2cd49aa881b1b9dbc4f0abc203d5eaff11dd (diff)
downloadopenembedded-5cb3bdc4a3151c4ee9f7822e75ac9bf6d70395a4.tar.gz
xorg: bump packages 2010-06-22
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-app')
-rw-r--r--recipes/xorg-app/sessreg_1.0.6.bb10
-rw-r--r--recipes/xorg-app/xinput_1.5.2.bb8
-rw-r--r--recipes/xorg-app/xlsatoms_1.1.0.bb8
-rw-r--r--recipes/xorg-app/xlsclients/strnlen.h32
-rw-r--r--recipes/xorg-app/xlsclients_1.1.0.bb14
-rw-r--r--recipes/xorg-app/xlsfonts_1.0.3.bb8
6 files changed, 80 insertions, 0 deletions
diff --git a/recipes/xorg-app/sessreg_1.0.6.bb b/recipes/xorg-app/sessreg_1.0.6.bb
new file mode 100644
index 0000000000..ae77ec98cd
--- /dev/null
+++ b/recipes/xorg-app/sessreg_1.0.6.bb
@@ -0,0 +1,10 @@
+require xorg-app-common.inc
+PE = "1"
+PR = "${INC_PR}.0"
+
+DESCRIPTION = "a simple program for managing utmp/wtmp entries"
+
+DEPENDS += " virtual/libx11"
+
+SRC_URI[archive.md5sum] = "8c8fcda19f4cffe573d43ec9b8255f8e"
+SRC_URI[archive.sha256sum] = "73f31670842b7d969504a61f3c694bf1911f844831c390396971ae2b74de7190"
diff --git a/recipes/xorg-app/xinput_1.5.2.bb b/recipes/xorg-app/xinput_1.5.2.bb
new file mode 100644
index 0000000000..d811748ddb
--- /dev/null
+++ b/recipes/xorg-app/xinput_1.5.2.bb
@@ -0,0 +1,8 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "a utility to configure and test XInput devices"
+DEPENDS += " libxi"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "8cec6023f90180cb8e4be31d98c43fda"
+SRC_URI[archive.sha256sum] = "2ce78601dc9289515749ef11d3af9d09d68c93f3efe69701112e95dd0da76390"
diff --git a/recipes/xorg-app/xlsatoms_1.1.0.bb b/recipes/xorg-app/xlsatoms_1.1.0.bb
new file mode 100644
index 0000000000..e550aab933
--- /dev/null
+++ b/recipes/xorg-app/xlsatoms_1.1.0.bb
@@ -0,0 +1,8 @@
+require xorg-app-common.inc
+PE = "1"
+PR = "${INC_PR}.0"
+
+DEPENDS += " libxcb"
+
+SRC_URI[archive.md5sum] = "c543ccb6489b629d427810d9a57d0724"
+SRC_URI[archive.sha256sum] = "4a017ada25140a71034fc0026500ebe24b81f2d185a4b2ef733de683b79dcb0d"
diff --git a/recipes/xorg-app/xlsclients/strnlen.h b/recipes/xorg-app/xlsclients/strnlen.h
new file mode 100644
index 0000000000..e1cdb85101
--- /dev/null
+++ b/recipes/xorg-app/xlsclients/strnlen.h
@@ -0,0 +1,32 @@
+/*
+ * Copyright (c) 2009 Apple Inc.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and associated documentation files (the "Software"),
+ * to deal in the Software without restriction, including without limitation
+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ * and/or sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in
+ * all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+ * THE ABOVE LISTED COPYRIGHT HOLDER(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
+ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ * DEALINGS IN THE SOFTWARE.
+ */
+
+ /*
+ * Author: Jeremy Huddleston, Apple Inc.
+ */
+
+#ifndef __STRNLEN_H__
+#define __STRNLEN_H__ 1
+#include <stdlib.h>
+
+extern size_t strnlen(const char *s, size_t maxlen);
+#endif /* __STRNLEN_H__ */
diff --git a/recipes/xorg-app/xlsclients_1.1.0.bb b/recipes/xorg-app/xlsclients_1.1.0.bb
new file mode 100644
index 0000000000..2a2e4aec50
--- /dev/null
+++ b/recipes/xorg-app/xlsclients_1.1.0.bb
@@ -0,0 +1,14 @@
+require xorg-app-common.inc
+PE = "1"
+PR = "${INC_PR}.0"
+
+# missing file from source archive, fixed just after release in http://cgit.freedesktop.org/xorg/app/xlsclients/commit/?id=f30f41b8dc37e775279835c97f2bea83a513dc10
+SRC_URI += "file://strnlen.h"
+
+DEPENDS += " virtual/libx11 xcb-util"
+
+do_compile_prepend() {
+ mv ${WORKDIR}/strnlen.h ${S}
+}
+SRC_URI[archive.md5sum] = "550a0fee047c5043f2cbf190b41f8a1b"
+SRC_URI[archive.sha256sum] = "f95b51f55399f46ce5f597a68ccd04a0d68c5770b517428201262bff09bcfa0c"
diff --git a/recipes/xorg-app/xlsfonts_1.0.3.bb b/recipes/xorg-app/xlsfonts_1.0.3.bb
new file mode 100644
index 0000000000..b5c51e4971
--- /dev/null
+++ b/recipes/xorg-app/xlsfonts_1.0.3.bb
@@ -0,0 +1,8 @@
+require xorg-app-common.inc
+PR = "${INC_PR}.0"
+
+DESCRIPTION = "server font list displayer for X"
+DEPENDS += " virtual/libx11"
+
+SRC_URI[archive.md5sum] = "bf6f3e7074479839d5182ffed735d2be"
+SRC_URI[archive.sha256sum] = "b59358b664f8220e3856d01d6b3e60adcc70f04fc588d71e0f7d9fd35e0e67c2"