aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-app
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/xorg-app
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/xorg-app')
-rw-r--r--recipes/xorg-app/mkfontdir_1.0.3.bb2
-rw-r--r--recipes/xorg-app/mkfontdir_1.0.4.bb2
-rw-r--r--recipes/xorg-app/mkfontdir_1.0.5.bb2
-rw-r--r--recipes/xorg-app/xman_1.0.2.bb2
-rw-r--r--recipes/xorg-app/xman_1.0.3.bb2
-rw-r--r--recipes/xorg-app/xman_1.1.0.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes/xorg-app/mkfontdir_1.0.3.bb b/recipes/xorg-app/mkfontdir_1.0.3.bb
index bdbab32ab6..8ee6f9c51a 100644
--- a/recipes/xorg-app/mkfontdir_1.0.3.bb
+++ b/recipes/xorg-app/mkfontdir_1.0.3.bb
@@ -2,7 +2,7 @@ require xorg-app-common.inc
PE = "1"
-RDEPENDS += "mkfontscale"
+RDEPENDS_${PN} += "mkfontscale"
SRC_URI[archive.md5sum] = "4d0f89a23f77e22f1671a77bf0898955"
diff --git a/recipes/xorg-app/mkfontdir_1.0.4.bb b/recipes/xorg-app/mkfontdir_1.0.4.bb
index b8c0452488..7cc84ce963 100644
--- a/recipes/xorg-app/mkfontdir_1.0.4.bb
+++ b/recipes/xorg-app/mkfontdir_1.0.4.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "a program to create an index of X font files in a directory"
PE = "1"
-RDEPENDS += "mkfontscale"
+RDEPENDS_${PN} += "mkfontscale"
SRC_URI[archive.md5sum] = "35394bf3f746a57fba624dba52fdbba3"
diff --git a/recipes/xorg-app/mkfontdir_1.0.5.bb b/recipes/xorg-app/mkfontdir_1.0.5.bb
index 8539023a44..ec75d30768 100644
--- a/recipes/xorg-app/mkfontdir_1.0.5.bb
+++ b/recipes/xorg-app/mkfontdir_1.0.5.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "a program to create an index of X font files in a directory"
PE = "1"
-RDEPENDS += "mkfontscale"
+RDEPENDS_${PN} += "mkfontscale"
SRC_URI[archive.md5sum] = "9365ac66d19186eaf030482d312fca06"
diff --git a/recipes/xorg-app/xman_1.0.2.bb b/recipes/xorg-app/xman_1.0.2.bb
index c6db560274..dbaa9d273a 100644
--- a/recipes/xorg-app/xman_1.0.2.bb
+++ b/recipes/xorg-app/xman_1.0.2.bb
@@ -2,7 +2,7 @@ require xorg-app-common.inc
PE = "1"
DEPENDS += " libxaw libxprintutil libxp libxt"
-RDEPENDS = " man"
+RDEPENDS_${PN} = " man"
FILES_${PN} += " /usr/share/X11/xman.help"
diff --git a/recipes/xorg-app/xman_1.0.3.bb b/recipes/xorg-app/xman_1.0.3.bb
index c858f8ca08..40c4009178 100644
--- a/recipes/xorg-app/xman_1.0.3.bb
+++ b/recipes/xorg-app/xman_1.0.3.bb
@@ -2,7 +2,7 @@ require xorg-app-common.inc
DESCRIPTION = "manual page browser for X"
DEPENDS += " libxaw libxprintutil libxp libxt"
-RDEPENDS = " man"
+RDEPENDS_${PN} = " man"
PE = "1"
FILES_${PN} += " /usr/share/X11/xman.help"
diff --git a/recipes/xorg-app/xman_1.1.0.bb b/recipes/xorg-app/xman_1.1.0.bb
index aba92aebb8..e51e67dbfd 100644
--- a/recipes/xorg-app/xman_1.1.0.bb
+++ b/recipes/xorg-app/xman_1.1.0.bb
@@ -2,7 +2,7 @@ require xorg-app-common.inc
DESCRIPTION = "manual page browser for X"
DEPENDS += " libxaw libxprintutil libxp libxt"
-RDEPENDS = " man"
+RDEPENDS_${PN} = " man"
PE = "1"
FILES_${PN} += " /usr/share/X11/xman.help"