aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-app
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-12 10:15:09 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-12 10:15:09 +0000
commite0977a85cb7eb9cf37fb9bb44a465368a0481dd7 (patch)
tree516b1d4a488f8e5465c0fa90a3bfdbf41f8eae90 /recipes/xorg-app
parentdf9f3b227447230ebeb505fb205a3d9be6577b66 (diff)
downloadopenembedded-e0977a85cb7eb9cf37fb9bb44a465368a0481dd7.tar.gz
xterm_251.bb : really add latest version of xterm
Diffstat (limited to 'recipes/xorg-app')
-rw-r--r--recipes/xorg-app/xterm_251.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/xorg-app/xterm_251.bb b/recipes/xorg-app/xterm_251.bb
new file mode 100644
index 0000000000..5764da39fe
--- /dev/null
+++ b/recipes/xorg-app/xterm_251.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "xterm is the standard terminal emulator for the X Window System."
+SECTION = "x11/applications"
+LICENSE = "MIT-X"
+
+DEPENDS = "libxaw xproto virtual/libx11 xextproto xext xau libxpm ncurses"
+
+SRC_URI = "ftp://invisible-island.net/xterm/${PN}-${PV}.tgz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += " /usr/lib/X11"
+
+#EXTRA_OERECONF = " -I${S}/xterm.m4"
+EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config --disable-imake"
+
+#do_configure_prepend () {
+# mv ${S}/aclocal.m4 ${S}/xterm.m4
+#}
+do_configure() {
+
+ sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
+
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}