aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib/libx11-1.0.1
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-24 20:09:24 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-25 15:44:27 +0200
commit82dd23467d2a7dd7c3c2b3a32635f8e925c7d589 (patch)
treed04ae6ce563ea118c26c3ba546a3b9639bc5e4d7 /recipes/xorg-lib/libx11-1.0.1
parent2e0f5099dae869f19984b67a75ff166b345b31db (diff)
downloadopenembedded-82dd23467d2a7dd7c3c2b3a32635f8e925c7d589.tar.gz
libx11: convert to BBCLASSEXTEND
* common patches in new libx11.inc (some needed to be renamed to keep same name across version) * keep one common dir with diet-x11/libx11-trip variants * enable xcb again for non-native non-sdk versions newer than 1.3 and add libx11-xcb package, XCB seems more popular then in 2007 (xls* projects were coverted lately, so this actually reverts patch from bug #3372) * also xcb enabled makes mesa build after libxcb was staged (mesa itself has xcb disabled, but if it founds libxcb, then it expects to find libx11 with xcb too) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-lib/libx11-1.0.1')
-rw-r--r--recipes/xorg-lib/libx11-1.0.1/keysymdef_include.patch62
-rw-r--r--recipes/xorg-lib/libx11-1.0.1/x11_disable_makekeys.patch15
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11-1.0.1/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.0.1/keysymdef_include.patch
new file mode 100644
index 0000000000..565308834e
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.0.1/keysymdef_include.patch
@@ -0,0 +1,62 @@
+---
+ configure.ac | 44 ++++++++++++++++++++++++--------------------
+ 1 file changed, 24 insertions(+), 20 deletions(-)
+
+Index: libX11-1.1.2/configure.ac
+===================================================================
+--- libX11-1.1.2.orig/configure.ac 2008-01-02 15:30:47.000000000 +0000
++++ libX11-1.1.2/configure.ac 2008-01-02 15:47:25.000000000 +0000
+@@ -207,29 +207,33 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL,
+ #
+ KEYSYMDEF=""
+ AC_MSG_CHECKING([keysymdef.h])
+-for flag in $XPROTO_CFLAGS -I/usr/include; do
+- case "$KEYSYMDEF" in
+- "")
+- case "$flag" in
+- *-I*)
+- dir=`echo "$flag" | sed 's/ *-I//'`
+- file="$dir/X11/keysymdef.h"
+- if test -f "$file"; then
+- KEYSYMDEF="$file"
+- fi
++AC_ARG_WITH(keysymdef,
++ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
++ KEYSYMDEF=$withval, KEYSYMDEF="")
++
++if test x$KEYSYMDEF = x; then
++ for flag in $XPROTO_CFLAGS -I/usr/include; do
++ case "$KEYSYMDEF" in
++ "")
++ case "$flag" in
++ *-I*)
++ dir=`echo "$flag" | sed 's/ *-I//'`
++ file="$dir/X11/keysymdef.h"
++ if test -f "$file"; then
++ KEYSYMDEF="$file"
++ fi
++ ;;
++ esac
+ ;;
+ esac
+- ;;
+- esac
+-done
+-case "$KEYSYMDEF" in
+-"")
+- AC_MSG_ERROR([Cannot find keysymdef.h])
+- ;;
+-*)
++ done
++fi
++
++if test -f "$KEYSYMDEF"; then
+ AC_MSG_RESULT([$KEYSYMDEF])
+- ;;
+-esac
++else
++ AC_MSG_ERROR([Cannot find keysymdef.h])
++fi
+ AC_SUBST(KEYSYMDEF)
+
+ AC_ARG_ENABLE(udc,
diff --git a/recipes/xorg-lib/libx11-1.0.1/x11_disable_makekeys.patch b/recipes/xorg-lib/libx11-1.0.1/x11_disable_makekeys.patch
new file mode 100644
index 0000000000..ad8b6fc7b6
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.0.1/x11_disable_makekeys.patch
@@ -0,0 +1,15 @@
+Index: libX11-1.0.1/src/util/Makefile.am
+===================================================================
+--- libX11-1.0.1.old/src/util/Makefile.am
++++ libX11-1.0.1/src/util/Makefile.am
+@@ -1,10 +1 @@
+-# $XdotOrg: lib/X11/src/util/Makefile.am,v 1.4 2006-02-19 02:14:12 jamey Exp $
+-
+-noinst_PROGRAMS=makekeys
+-
+-makekeys_CFLAGS=$(X11_CFLAGS)
+-
+-#override CC = gcc
+-LINK = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+-
+ EXTRA_DIST = mkks.sh