aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-11 09:00:12 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-13 08:26:49 +0100
commit7e94eaa1951452129aa18e704303c2b7b5e182b4 (patch)
tree9e8f0c4758070b8602df74413084eadec0421c36 /recipes/xorg-xserver
parentce6c525eb2991e3285c7bee504eac2f3a6b18d62 (diff)
downloadopenembedded-7e94eaa1951452129aa18e704303c2b7b5e182b4.tar.gz
xorg-xserver: obsolete old versions
Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.7.1/dolt-fix.patch22
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.7.1/randr-support.patch96
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.7.1/sysroot_fix.patch13
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.8.1/dolt-fix.patch22
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.8.1/hack-assume-pixman-supports-overlapped-blt.patch14
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.8.1/hack-fbdev-ignore-return-mode.patch39
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.8.1/randr-support.patch96
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.1.bb22
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.8.1.bb33
9 files changed, 0 insertions, 357 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-1.7.1/dolt-fix.patch b/recipes/xorg-xserver/xserver-xorg-1.7.1/dolt-fix.patch
deleted file mode 100644
index e332ce0bbe..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.7.1/dolt-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: xorg-server/m4/dolt.m4
-===================================================================
---- xorg-server.orig/m4/dolt.m4 2009-04-14 21:14:56.000000000 +0400
-+++ xorg-server/m4/dolt.m4 2009-07-15 12:38:33.796848843 +0400
-@@ -147,7 +147,7 @@
- cat <<__DOLTLIBTOOL__EOF__ > doltlibtool
- #!$DOLT_BASH
- __DOLTLIBTOOL__EOF__
-- cat <<'__DOLTLIBTOOL__EOF__' >>doltlibtool
-+ cat <<'__DOLTLIBTOOL__EOF__' | sed -e "s/@host_alias@/$host_alias/g" >>doltlibtool
- top_builddir_slash="${0%%doltlibtool}"
- : ${top_builddir_slash:=./}
- args=()
-@@ -163,7 +163,7 @@
- if $modeok && $tagok ; then
- . ${top_builddir_slash}doltcompile "${args@<:@@@:>@}"
- else
-- exec ${top_builddir_slash}libtool "$[]@"
-+ exec ${top_builddir_slash}@host_alias@-libtool "$[]@"
- fi
- __DOLTLIBTOOL__EOF__
-
diff --git a/recipes/xorg-xserver/xserver-xorg-1.7.1/randr-support.patch b/recipes/xorg-xserver/xserver-xorg-1.7.1/randr-support.patch
deleted file mode 100644
index fb8d3815be..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.7.1/randr-support.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff -Nur xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c
---- xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c 2009-09-24 07:12:00.000000000 +0200
-+++ xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c 2009-10-08 11:45:50.000000000 +0200
-@@ -95,6 +95,8 @@
-
- #include "os.h"
-
-+#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
-+
- EventListPtr xf86Events = NULL;
-
- /**
-@@ -1086,4 +1088,67 @@
- EnableDevice(dev, TRUE);
- }
-
-+/* Taken from evdev-properties.h. */
-+#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
-+#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
-+
-+/* This is a hack until we get device -> CRTC association. */
-+void
-+xf86InputRotationNotify(Rotation rotation)
-+{
-+ DeviceIntPtr dev;
-+ LocalDevicePtr local;
-+ int ret;
-+ int swap_axes = 0;
-+ CARD8 invert[2] = { 0, 0 };
-+ static Atom prop_swap = 0, prop_invert = 0;
-+ static int atom_generation = -1;
-+
-+ if (atom_generation != serverGeneration) {
-+ prop_swap = 0;
-+ prop_invert = 0;
-+ }
-+
-+ switch (rotation & RR_Rotate_All) {
-+ case RR_Rotate_0:
-+ break;
-+ case RR_Rotate_90:
-+ swap_axes = 1;
-+ invert[0] = 1;
-+ break;
-+ case RR_Rotate_180:
-+ invert[0] = 1;
-+ invert[1] = 1;
-+ break;
-+ case RR_Rotate_270:
-+ swap_axes = 1;
-+ invert[1] = 1;
-+ break;
-+ }
-+
-+ if (!prop_swap)
-+ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
-+ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
-+ if (!prop_invert)
-+ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
-+ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
-+
-+ for (dev = inputInfo.devices; dev; dev = dev->next) {
-+ local = dev->public.devicePrivate;
-+ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
-+ PropModeReplace, 1, &swap_axes, FALSE);
-+ if (ret != Success) {
-+ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
-+ continue;
-+ }
-+ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
-+ PropModeReplace, 2, invert, FALSE);
-+ if (ret != Success) {
-+ xf86Msg(X_ERROR, "Changing invert property failed!\n");
-+ continue;
-+ }
-+ }
-+}
-+
-+
- /* end of xf86Xinput.c */
-diff -Nur xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c
---- xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c 2009-10-01 08:27:36.000000000 +0200
-+++ xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c 2009-10-08 11:28:42.000000000 +0200
-@@ -391,6 +391,12 @@
- if (didLock)
- crtc->funcs->unlock (crtc);
-
-+ /*
-+ * Rotate Touchscreen
-+ */
-+ xf86InputRotationNotify(crtc->rotation);
-+
-+
- return ret;
- }
-
diff --git a/recipes/xorg-xserver/xserver-xorg-1.7.1/sysroot_fix.patch b/recipes/xorg-xserver/xserver-xorg-1.7.1/sysroot_fix.patch
deleted file mode 100644
index 59753d5803..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.7.1/sysroot_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: xorg-server-1.4/xorg-server.m4
-===================================================================
---- xorg-server-1.4.orig/xorg-server.m4 2008-03-15 20:09:36.000000000 +0100
-+++ xorg-server-1.4/xorg-server.m4 2008-03-15 20:09:51.000000000 +0100
-@@ -30,7 +30,7 @@
-
- AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
- SAVE_CFLAGS="$CFLAGS"
-- CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`"
-+ CFLAGS="$CFLAGS `pkg-config --cflags xorg-server`"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include "xorg-server.h"
- #if !defined $1
diff --git a/recipes/xorg-xserver/xserver-xorg-1.8.1/dolt-fix.patch b/recipes/xorg-xserver/xserver-xorg-1.8.1/dolt-fix.patch
deleted file mode 100644
index e332ce0bbe..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.8.1/dolt-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: xorg-server/m4/dolt.m4
-===================================================================
---- xorg-server.orig/m4/dolt.m4 2009-04-14 21:14:56.000000000 +0400
-+++ xorg-server/m4/dolt.m4 2009-07-15 12:38:33.796848843 +0400
-@@ -147,7 +147,7 @@
- cat <<__DOLTLIBTOOL__EOF__ > doltlibtool
- #!$DOLT_BASH
- __DOLTLIBTOOL__EOF__
-- cat <<'__DOLTLIBTOOL__EOF__' >>doltlibtool
-+ cat <<'__DOLTLIBTOOL__EOF__' | sed -e "s/@host_alias@/$host_alias/g" >>doltlibtool
- top_builddir_slash="${0%%doltlibtool}"
- : ${top_builddir_slash:=./}
- args=()
-@@ -163,7 +163,7 @@
- if $modeok && $tagok ; then
- . ${top_builddir_slash}doltcompile "${args@<:@@@:>@}"
- else
-- exec ${top_builddir_slash}libtool "$[]@"
-+ exec ${top_builddir_slash}@host_alias@-libtool "$[]@"
- fi
- __DOLTLIBTOOL__EOF__
-
diff --git a/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-assume-pixman-supports-overlapped-blt.patch b/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-assume-pixman-supports-overlapped-blt.patch
deleted file mode 100644
index a947582f15..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-assume-pixman-supports-overlapped-blt.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/fb/fbcopy.c b/fb/fbcopy.c
-index 07eb663..ba394b7 100644
---- a/fb/fbcopy.c
-+++ b/fb/fbcopy.c
-@@ -91,8 +91,7 @@ fbCopyNtoN (DrawablePtr pSrcDrawable,
- while (nbox--)
- {
- #ifndef FB_ACCESS_WRAPPER /* pixman_blt() doesn't support accessors yet */
-- if (pm == FB_ALLONES && alu == GXcopy && !reverse &&
-- !upsidedown)
-+ if (pm == FB_ALLONES && alu == GXcopy)
- {
- if (!pixman_blt ((uint32_t *)src, (uint32_t *)dst, srcStride, dstStride, srcBpp, dstBpp,
- (pbox->x1 + dx + srcXoff),
diff --git a/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-fbdev-ignore-return-mode.patch b/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-fbdev-ignore-return-mode.patch
deleted file mode 100644
index d3661cbea2..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.8.1/hack-fbdev-ignore-return-mode.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Ugly hack that prevents server termination with xf86-video-fbdev-0.4.1
-(and probably other) while returning from chvt or resume on some
-hardware (e. g. zaurus).
-
-Correct fix would require debugging of fbdev mode during LeaveVT and
-EnterVT.
-
-This patch may cause staying in incorrect or corrupted display mode
-after EnterVT, but on man affected devices it does not cause any visible
-problems.
-
-Hacked code is never called on properly written drivers.
-
-Devices affected and testers involved for future patch removal:
-Sharp Zaurus (spitz/akita): Stanislav Brabec <utx@penguin.cz>
-
-See also:
-https://bugzilla.redhat.com/show_bug.cgi?id=238451
-
-The bug (first line indicates that your device is affected):
-
-(EE) FBDEV(0): FBIOPUT_VSCREENINFO succeeded but modified mode
-
-Fatal server error:
-EnterVT failed for screen 0
-
-Index: xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
-===================================================================
---- xorg-server-1.7.3.orig/hw/xfree86/fbdevhw/fbdevhw.c
-+++ xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
-@@ -571,7 +571,7 @@ fbdevHWSetMode(ScrnInfoPtr pScrn, Displa
- #if DEBUG
- print_fbdev_mode("returned", &set_var);
- #endif
-- return FALSE;
-+ /* return FALSE; UGLY HACK to allow return from chvt */
- }
-
- if (!check)
diff --git a/recipes/xorg-xserver/xserver-xorg-1.8.1/randr-support.patch b/recipes/xorg-xserver/xserver-xorg-1.8.1/randr-support.patch
deleted file mode 100644
index fb8d3815be..0000000000
--- a/recipes/xorg-xserver/xserver-xorg-1.8.1/randr-support.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff -Nur xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c
---- xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c 2009-09-24 07:12:00.000000000 +0200
-+++ xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c 2009-10-08 11:45:50.000000000 +0200
-@@ -95,6 +95,8 @@
-
- #include "os.h"
-
-+#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
-+
- EventListPtr xf86Events = NULL;
-
- /**
-@@ -1086,4 +1088,67 @@
- EnableDevice(dev, TRUE);
- }
-
-+/* Taken from evdev-properties.h. */
-+#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
-+#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
-+
-+/* This is a hack until we get device -> CRTC association. */
-+void
-+xf86InputRotationNotify(Rotation rotation)
-+{
-+ DeviceIntPtr dev;
-+ LocalDevicePtr local;
-+ int ret;
-+ int swap_axes = 0;
-+ CARD8 invert[2] = { 0, 0 };
-+ static Atom prop_swap = 0, prop_invert = 0;
-+ static int atom_generation = -1;
-+
-+ if (atom_generation != serverGeneration) {
-+ prop_swap = 0;
-+ prop_invert = 0;
-+ }
-+
-+ switch (rotation & RR_Rotate_All) {
-+ case RR_Rotate_0:
-+ break;
-+ case RR_Rotate_90:
-+ swap_axes = 1;
-+ invert[0] = 1;
-+ break;
-+ case RR_Rotate_180:
-+ invert[0] = 1;
-+ invert[1] = 1;
-+ break;
-+ case RR_Rotate_270:
-+ swap_axes = 1;
-+ invert[1] = 1;
-+ break;
-+ }
-+
-+ if (!prop_swap)
-+ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
-+ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
-+ if (!prop_invert)
-+ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
-+ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
-+
-+ for (dev = inputInfo.devices; dev; dev = dev->next) {
-+ local = dev->public.devicePrivate;
-+ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
-+ PropModeReplace, 1, &swap_axes, FALSE);
-+ if (ret != Success) {
-+ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
-+ continue;
-+ }
-+ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
-+ PropModeReplace, 2, invert, FALSE);
-+ if (ret != Success) {
-+ xf86Msg(X_ERROR, "Changing invert property failed!\n");
-+ continue;
-+ }
-+ }
-+}
-+
-+
- /* end of xf86Xinput.c */
-diff -Nur xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c
---- xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c 2009-10-01 08:27:36.000000000 +0200
-+++ xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c 2009-10-08 11:28:42.000000000 +0200
-@@ -391,6 +391,12 @@
- if (didLock)
- crtc->funcs->unlock (crtc);
-
-+ /*
-+ * Rotate Touchscreen
-+ */
-+ xf86InputRotationNotify(crtc->rotation);
-+
-+
- return ret;
- }
-
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.1.bb b/recipes/xorg-xserver/xserver-xorg_1.7.1.bb
deleted file mode 100644
index 60d45754bd..0000000000
--- a/recipes/xorg-xserver/xserver-xorg_1.7.1.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-require xorg-xserver-common.inc
-
-DESCRIPTION = "the X.Org X server"
-DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
-PE = "2"
-PR = "${INC_PR}.1"
-
-SRC_URI += "file://sysroot_fix.patch \
- file://dolt-fix.patch \
- file://randr-support.patch \
- "
-do_install_prepend() {
- mkdir -p ${D}/${libdir}/X11/fonts
-}
-
-EXTRA_OECONF += "--disable-xephyr --disable-config-hal --disable-xinerama --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
-EXTRA_OECONF += " --enable-dri2 --disable-unit-tests "
-
-export LDFLAGS += " -ldl "
-
-SRC_URI[archive.md5sum] = "dda7842467cda6018fdc87e6002e4db1"
-SRC_URI[archive.sha256sum] = "a58c0de29cbd2b7d1a1ac5ee70a94ad1ed2a085132803c0ca83f2dd8513b4c20"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.8.1.bb b/recipes/xorg-xserver/xserver-xorg_1.8.1.bb
deleted file mode 100644
index 31ce24a53b..0000000000
--- a/recipes/xorg-xserver/xserver-xorg_1.8.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-# Assign it here, since the hal->udev transition happens post 1.7 in angstrom
-DISTRO_XORG_CONFIG_MANAGER_angstrom = "udev"
-
-require xorg-xserver-common.inc
-
-DESCRIPTION = "the X.Org X server"
-DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
-PE = "2"
-PR = "${INC_PR}.2"
-
-SRC_URI += " \
- file://dolt-fix.patch \
- file://randr-support.patch \
- file://hack-fbdev-ignore-return-mode.patch \
- "
-SRC_URI[archive.md5sum] = "7c3b873692f4e93938261d774510e78d"
-SRC_URI[archive.sha256sum] = "bddb974d8f21107ab8f79abf92cebb06ec13243f1ffd1ef56b48452c4994659d"
-
-SRC_URI_append_angstrom = " file://hack-assume-pixman-supports-overlapped-blt.patch"
-SRC_URI_append_shr = " file://hack-assume-pixman-supports-overlapped-blt.patch"
-
-do_install_prepend() {
- mkdir -p ${D}/${libdir}/X11/fonts
-}
-
-# The NVidia driver requires Xinerama support in the X server. Ion uses it.
-PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
-XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
-
-EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
-EXTRA_OECONF += " --enable-dri2 --disable-unit-tests "
-
-export LDFLAGS += " -ldl "