aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-06-30 13:37:30 +0000
committerKhem Raj <raj.khem@gmail.com>2010-07-02 21:21:27 -0700
commit9fcdf57b3e5325785f9b83beb67e92c6d82df580 (patch)
tree49bbc9d5c314bb0f19f3b196665db92585b3ec14 /recipes/xorg-xserver
parentfaf4cb936e774a2077d56e1c0dac23cc1a1d46cd (diff)
downloadopenembedded-9fcdf57b3e5325785f9b83beb67e92c6d82df580.tar.gz
xserver-kdrive_1.5.3.bb: add openssl to DEPENDS.
The build fails without openssl. | mipsel-oe-linux-libtool: compile: ccache mipsel-oe-linux-gcc -march=mips32 -DHAVE_CONFIG_H -I. -I../include -isystem/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include/freetype2 -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include/pixman-1 -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include/hal -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include/dbus-1.0 -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/lib/dbus-1.0/include -I/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/home/grg/oe2/tmp/sysroots/x86_64-linux/usr/include -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I/home/ grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include/xextproto-70 -isystem/home/grg/oe2/tmp/sysroots/mipsel-oe-linux/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -MT glyph.lo -MD -MP -MF .deps/glyph.Tpo -c glyph.c -fPIC -DPIC -o .libs/glyph.o | glyph.c:30:25: error: openssl/sha.h: No such file or directory | glyph.c: In function 'HashGlyph': | glyph.c:205: error: 'SHA_CTX' undeclared (first use in this function) | glyph.c:205: error: (Each undeclared identifier is reported only once | glyph.c:205: error: for each function it appears in.) | glyph.c:205: error: expected ';' before 'ctx' | glyph.c:208: warning: implicit declaration of function 'SHA1_Init' | glyph.c:208: warning: nested extern declaration of 'SHA1_Init' | glyph.c:208: error: 'ctx' undeclared (first use in this function) | glyph.c:212: warning: implicit declaration of function 'SHA1_Update' | glyph.c:212: warning: nested extern declaration of 'SHA1_Update' | glyph.c:220: warning: implicit declaration of function 'SHA1_Final' | glyph.c:220: warning: nested extern declaration of 'SHA1_Final' | make[1]: *** [glyph.lo] Error 1 Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-kdrive_1.5.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/xorg-xserver/xserver-kdrive_1.5.3.bb b/recipes/xorg-xserver/xserver-kdrive_1.5.3.bb
index 7250a61b74..7fbdff2753 100644
--- a/recipes/xorg-xserver/xserver-kdrive_1.5.3.bb
+++ b/recipes/xorg-xserver/xserver-kdrive_1.5.3.bb
@@ -1,6 +1,6 @@
require xserver-kdrive-common.inc
-DEPENDS += "hal libxkbfile libxcalibrate pixman"
+DEPENDS += "hal libxkbfile libxcalibrate pixman openssl"
RDEPENDS_${PN} += "hal"
DEFAULT_PREFERENCE = "-99"