aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xscrnsaverh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xscrnsaverh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xscrnsaverh')
-rw-r--r--recipes/xscrnsaverh/xscrnsaverh-1.0/scrnsaver.h149
-rw-r--r--recipes/xscrnsaverh/xscrnsaverh_1.0.bb13
2 files changed, 162 insertions, 0 deletions
diff --git a/recipes/xscrnsaverh/xscrnsaverh-1.0/scrnsaver.h b/recipes/xscrnsaverh/xscrnsaverh-1.0/scrnsaver.h
new file mode 100644
index 0000000000..b20a648517
--- /dev/null
+++ b/recipes/xscrnsaverh/xscrnsaverh-1.0/scrnsaver.h
@@ -0,0 +1,149 @@
+/*
+ * $XConsortium: scrnsaver.h,v 1.6 94/04/17 20:59:34 keith Exp $
+ *
+Copyright (c) 1992 X Consortium
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the name of the X Consortium shall not be
+used in advertising or otherwise to promote the sale, use or other dealings
+in this Software without prior written authorization from the X Consortium.
+ *
+ * Author: Keith Packard, MIT X Consortium
+ */
+
+#ifndef _SCRNSAVER_H_
+#define _SCRNSAVER_H_
+
+#include <X11/Xfuncproto.h>
+#include <X11/extensions/saver.h>
+
+typedef struct {
+ int type; /* of event */
+ unsigned long serial; /* # of last request processed by server */
+ Bool send_event; /* true if this came frome a SendEvent request */
+ Display *display; /* Display the event was read from */
+ Window window; /* screen saver window */
+ Window root; /* root window of event screen */
+ int state; /* ScreenSaverOff, ScreenSaverOn, ScreenSaverCycle*/
+ int kind; /* ScreenSaverBlanked, ...Internal, ...External */
+ Bool forced; /* extents of new region */
+ Time time; /* event timestamp */
+} XScreenSaverNotifyEvent;
+
+typedef struct {
+ Window window; /* screen saver window - may not exist */
+ int state; /* ScreenSaverOff, ScreenSaverOn, ScreenSaverDisabled*/
+ int kind; /* ScreenSaverBlanked, ...Internal, ...External */
+ unsigned long til_or_since; /* time til or since screen saver */
+ unsigned long idle; /* total time since last user input */
+ unsigned long eventMask; /* currently selected events for this client */
+} XScreenSaverInfo;
+
+_XFUNCPROTOBEGIN
+
+extern Bool XScreenSaverQueryExtension (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ int* /* event_base */,
+ int* /* error_base */
+#endif
+);
+
+extern Status XScreenSaverQueryVersion (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ int* /* major_version */,
+ int* /* minor_version */
+#endif
+);
+
+extern XScreenSaverInfo *XScreenSaverAllocInfo (
+#if NeedFunctionPrototypes
+ void
+#endif
+);
+
+extern Status XScreenSaverQueryInfo (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ Drawable /* drawable */,
+ XScreenSaverInfo* /* info */
+#endif
+);
+
+extern void XScreenSaverSelectInput (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ Drawable /* drawable */,
+ unsigned long /* eventMask */
+#endif
+);
+
+extern void XScreenSaverSetAttributes (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ Drawable /* drawable */,
+ int /* x */,
+ int /* y */,
+ unsigned int /* width */,
+ unsigned int /* height */,
+ unsigned int /* border_width */,
+ int /* depth */,
+ unsigned int /* class */,
+ Visual * /* visual */,
+ unsigned long /* valuemask */,
+ XSetWindowAttributes * /* attributes */
+#endif
+);
+
+extern void XScreenSaverUnsetAttributes (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ Drawable /* drawable */
+#endif
+);
+
+extern Status XScreenSaverRegister (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ int /* screen */,
+ XID /* xid */,
+ Atom /* type */
+#endif
+);
+
+extern Status XScreenSaverUnregister (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ int /* screen */
+#endif
+);
+
+extern Status XScreenSaverGetRegistered (
+#if NeedFunctionPrototypes
+ Display* /* display */,
+ int /* screen */,
+ XID* /* xid */,
+ Atom* /* type */
+#endif
+);
+
+_XFUNCPROTOEND
+
+#endif /* _SCRNSAVER_H_ */
diff --git a/recipes/xscrnsaverh/xscrnsaverh_1.0.bb b/recipes/xscrnsaverh/xscrnsaverh_1.0.bb
new file mode 100644
index 0000000000..2989054f44
--- /dev/null
+++ b/recipes/xscrnsaverh/xscrnsaverh_1.0.bb
@@ -0,0 +1,13 @@
+
+PR = "r0"
+
+DEPENDS = "libxext"
+SECTION = "x11"
+LICENSE = "X-MIT"
+DESCRIPTION = "missing header"
+
+SRC_URI = "file://scrnsaver.h"
+
+do_stage() {
+ install -m 0644 ${WORKDIR}/scrnsaver.h ${STAGING_INCDIR}/X11/extensions/
+}