aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xst
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-01 15:52:51 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-05-01 15:52:51 +0200
commit90a600967823fd98fcc2c3aa0efccb15ff2196a0 (patch)
tree1820f879035afdac9c80de55cd1e1179e6569e70 /recipes/xst
parent256ed158c755c4b4334bb59cc58051b4a53efb63 (diff)
downloadopenembedded-90a600967823fd98fcc2c3aa0efccb15ff2196a0.tar.gz
xst: Makefile fix - don't strip on install
Diffstat (limited to 'recipes/xst')
-rw-r--r--recipes/xst/files/makefile-fix.patch11
-rw-r--r--recipes/xst/xst_0.15.bb2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes/xst/files/makefile-fix.patch b/recipes/xst/files/makefile-fix.patch
new file mode 100644
index 0000000000..3af2d57d70
--- /dev/null
+++ b/recipes/xst/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.old 2005-08-27 01:13:47.000000000 +0200
++++ xst-0.15/Makefile 2009-05-01 15:48:15.000000000 +0200
+@@ -32,7 +32,7 @@
+
+ install-program: $(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS) $(DEPS)
diff --git a/recipes/xst/xst_0.15.bb b/recipes/xst/xst_0.15.bb
index 76ab7af26f..6d6156e778 100644
--- a/recipes/xst/xst_0.15.bb
+++ b/recipes/xst/xst_0.15.bb
@@ -5,3 +5,5 @@ SECTION = "gpe"
DESCRIPTION = "GPE configuration utility"
LICENSE = "GPL"
SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
+
+SRC_URI += "file://makefile-fix.patch;patch=1"