summaryrefslogtreecommitdiffstats
path: root/recipes/zaurusd/zaurusd_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zaurusd/zaurusd_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zaurusd/zaurusd_svn.bb')
-rw-r--r--recipes/zaurusd/zaurusd_svn.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/zaurusd/zaurusd_svn.bb b/recipes/zaurusd/zaurusd_svn.bb
new file mode 100644
index 0000000000..2ad405e419
--- /dev/null
+++ b/recipes/zaurusd/zaurusd_svn.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Daemon to handle device specifc features."
+SECTION = "base"
+LICENSE = "GPL"
+DEPENDS = "tslib"
+RDEPENDS = "procps"
+PV = "0.0+svn${SRCDATE}"
+PR = "r18"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
+ file://zaurus-hinge.in \
+ file://add-poodle.patch;patch=1 \
+ file://alsa-cxx00-default.state.patch;patch=1 \
+ file://alsa-6000x-default.state.patch;patch=1 \
+ file://disable-alsa-handling.patch;patch=1 \
+ file://zaurus-hinge.matchbox-portrait \
+ file://zaurus-hinge.matchbox-landscape \
+ file://tslib-1.diff;patch=1 \
+ file://zaurus-hinge.bl-on \
+ file://zaurus-hinge.bl-off \
+ file://01-check-toggle-landscape \
+ file://01-check-toggle-portait"
+
+
+S = "${WORKDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/zaurus-hinge.in ${S}/scripts
+}
+
+do_install_append() {
+ install -d "${D}/etc/zaurusd/hinge-landscape.d"
+ install -d "${D}/etc/zaurusd/hinge-portrait.d"
+ install -d "${D}/etc/zaurusd/hinge-close.d"
+ install -d ${D}/etc/apm/resume.d
+
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/apm/resume.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-landscape.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-portrait.d/00-backlight-on"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.bl-off" "${D}/etc/zaurusd/hinge-close.d/00-backlight-off"
+
+ install -m 0755 "${WORKDIR}/01-check-toggle-landscape" "${D}/etc/zaurusd/hinge-landscape.d/01-check-toggle"
+ install -m 0755 "${WORKDIR}/01-check-toggle-portait" "${D}/etc/zaurusd/hinge-portrait.d/01-check-toggle"
+
+ install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-landscape" "${D}/etc/zaurusd/hinge-landscape.d/20-matchbox-landscape"
+ install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-portrait" "${D}/etc/zaurusd/hinge-portrait.d/20-matchbox-portrait"
+}
+
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_NAME = "zaurusd"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."