aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zope
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zope
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zope')
-rw-r--r--recipes/zope/zope-native_3.3.1.bb10
-rw-r--r--recipes/zope/zope_3.3.1.bb49
2 files changed, 59 insertions, 0 deletions
diff --git a/recipes/zope/zope-native_3.3.1.bb b/recipes/zope/zope-native_3.3.1.bb
new file mode 100644
index 0000000000..970df6d785
--- /dev/null
+++ b/recipes/zope/zope-native_3.3.1.bb
@@ -0,0 +1,10 @@
+require zope_${PV}.bb
+inherit native
+
+DEPENDS = "python-native"
+
+inherit distutils-base
+
+export BUILD_SYS
+export HOST_SYS
+
diff --git a/recipes/zope/zope_3.3.1.bb b/recipes/zope/zope_3.3.1.bb
new file mode 100644
index 0000000000..05df3dd48d
--- /dev/null
+++ b/recipes/zope/zope_3.3.1.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "python"
+RDEPENDS = "python-core python-shell"
+LICENSE = "ZPL"
+PR = "r8"
+
+SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+S = "${WORKDIR}/Zope-${PV}"
+
+inherit distutils-base
+
+do_configure() {
+ ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
+}
+
+do_compile() {
+ oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS} STAGING_INCDIR=${STAGING_INCDIR}
+}
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+ mv ${D}${libdir}/python/* ${D}${libdir}/${PYTHON_DIR}
+ rm -rf ${D}${libdir}/${PYTHON_DIR}/twisted
+ rm -rf ${D}${libdir}/${PYTHON_DIR}/zope/app/twisted
+}
+
+PACKAGES =+ "python-zopeinterface python-zopeinterface-dbg"
+
+FILES_${PN} = "${prefix}"
+FILES_${PN}_doc = "${prefix}/doc"
+FILES_${PN}-dbg += "\
+${libdir}/${PYTHON_DIR}/BTrees/.debug \
+${libdir}/${PYTHON_DIR}/persistent/.debug \
+${libdir}/${PYTHON_DIR}/zope/proxy/.debug \
+${libdir}/${PYTHON_DIR}/zope/thread/.debug \
+${libdir}/${PYTHON_DIR}/zope/security/.debug \
+${libdir}/${PYTHON_DIR}/zope/hookable/.debug \
+${libdir}/${PYTHON_DIR}/zope/app/container/.debug \
+${libdir}/${PYTHON_DIR}/zope/i18nmessageid/.debug \
+${libdir}/${PYTHON_DIR}/ZODB/.debug"
+FILES_python-zopeinterface-dbg += "${libdir}/${PYTHON_DIR}/zope/interface/.debug "
+
+FILES_python-zopeinterface = " ${libdir}/${PYTHON_DIR}/zope/__init__.py* \
+ ${libdir}/${PYTHON_DIR}/zope/interface/*.* \
+ ${libdir}/${PYTHON_DIR}/zope/interface/common"
+