aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zope
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-03-27 18:16:40 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-03-27 18:17:37 +0100
commit75b82c6cc3c5f45e937968b593d669ac9fd7185f (patch)
treec0160e5334ee1e96283df1b3c41858ab6b542aa7 /recipes/zope
parentbb9b5dd8f35d0f7404a29c0a873bab88c039e712 (diff)
downloadopenembedded-75b82c6cc3c5f45e937968b593d669ac9fd7185f.tar.gz
zope-interfaces: new recipe; standalone Zope interfaces for extension products
adjust main zope recipe accordingly
Diffstat (limited to 'recipes/zope')
-rw-r--r--recipes/zope/zope-interfaces_3.3.0.bb9
-rw-r--r--recipes/zope/zope-native_3.3.1.bb3
-rw-r--r--recipes/zope/zope.inc39
-rw-r--r--recipes/zope/zope_3.3.1.bb3
4 files changed, 51 insertions, 3 deletions
diff --git a/recipes/zope/zope-interfaces_3.3.0.bb b/recipes/zope/zope-interfaces_3.3.0.bb
new file mode 100644
index 0000000000..85533910ff
--- /dev/null
+++ b/recipes/zope/zope-interfaces_3.3.0.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "Interface definitions for Zope products"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ZPL"
+
+inherit distutils
+
+SRC_URI = "http://pypi.python.org/packages/source/z/zope.interface/zope.interface-${PV}.tar.gz"
+S = "${WORKDIR}/zope.interface-${PV}"
diff --git a/recipes/zope/zope-native_3.3.1.bb b/recipes/zope/zope-native_3.3.1.bb
index 70d19e9888..cb0d6905ce 100644
--- a/recipes/zope/zope-native_3.3.1.bb
+++ b/recipes/zope/zope-native_3.3.1.bb
@@ -1,7 +1,6 @@
inherit native distutils-native-base
-require zope-${PV}.inc
+require zope.inc
export BUILD_SYS
export HOST_SYS
-
diff --git a/recipes/zope/zope.inc b/recipes/zope/zope.inc
new file mode 100644
index 0000000000..618b4c4a78
--- /dev/null
+++ b/recipes/zope/zope.inc
@@ -0,0 +1,39 @@
+DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ZPL"
+PR = "r10"
+
+SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+S = "${WORKDIR}/Zope-${PV}"
+
+do_configure() {
+ ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
+}
+
+do_compile() {
+ oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS} STAGING_INCDIR=${STAGING_INCDIR}
+}
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+ mv ${D}${libdir}/python/* ${D}${libdir}/${PYTHON_DIR}
+ rm -rf ${D}${libdir}/${PYTHON_DIR}/twisted
+ rm -rf ${D}${libdir}/${PYTHON_DIR}/zope/app/twisted
+ # shipped as seperate package
+ rm -rf ${D}${libdir}/${PYTHON_DIR}/zope/interface
+}
+
+FILES_${PN} = "${prefix}"
+FILES_${PN}_doc = "${prefix}/doc"
+FILES_${PN}-dbg += "\
+${libdir}/${PYTHON_DIR}/BTrees/.debug \
+${libdir}/${PYTHON_DIR}/persistent/.debug \
+${libdir}/${PYTHON_DIR}/zope/proxy/.debug \
+${libdir}/${PYTHON_DIR}/zope/thread/.debug \
+${libdir}/${PYTHON_DIR}/zope/security/.debug \
+${libdir}/${PYTHON_DIR}/zope/hookable/.debug \
+${libdir}/${PYTHON_DIR}/zope/app/container/.debug \
+${libdir}/${PYTHON_DIR}/zope/i18nmessageid/.debug \
+${libdir}/${PYTHON_DIR}/ZODB/.debug"
diff --git a/recipes/zope/zope_3.3.1.bb b/recipes/zope/zope_3.3.1.bb
index cf81b15fca..f0bb9888c9 100644
--- a/recipes/zope/zope_3.3.1.bb
+++ b/recipes/zope/zope_3.3.1.bb
@@ -1,5 +1,6 @@
RDEPENDS = "python-shell"
+RRECOMMENDS += "zope-interfaces"
inherit distutils-base
-require ${PN}-${PV}.inc
+require zope.inc