aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zsh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zsh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zsh')
-rw-r--r--recipes/zsh/zsh-4.1.1/configure.patch27
-rw-r--r--recipes/zsh/zsh_4.1.1.bb25
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes/zsh/zsh-4.1.1/configure.patch b/recipes/zsh/zsh-4.1.1/configure.patch
new file mode 100644
index 0000000000..3533d484b3
--- /dev/null
+++ b/recipes/zsh/zsh-4.1.1/configure.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zsh-4.1.1/zshconfig.ac~configure
++++ zsh-4.1.1/zshconfig.ac
+@@ -460,7 +460,7 @@
+ AC_PROG_MAKE_SET dnl Does make define $MAKE
+ AC_PROG_INSTALL dnl Check for BSD compatible `install'
+ AC_PROG_AWK dnl Check for mawk,gawk,nawk, then awk.
+-AC_PROG_LN dnl Check for working ln, for "make install"
++AC_PROG_LN_S dnl Check for working ln, for "make install"
+ AC_CHECK_PROGS([YODL], [yodl], [: yodl])
+ AC_CHECK_PROGS([ANSI2KNR], [ansi2knr], [: ansi2knr])
+
+--- zsh-4.1.1/Src/Makefile.in~configure
++++ zsh-4.1.1/Src/Makefile.in
+@@ -35,7 +35,7 @@
+ sdir = @srcdir@
+ sdir_top = @top_srcdir@
+ INSTALL = @INSTALL@
+-LN = @LN@
++LN = @LN_S@
+
+ @DEFS_MK@
+
diff --git a/recipes/zsh/zsh_4.1.1.bb b/recipes/zsh/zsh_4.1.1.bb
new file mode 100644
index 0000000000..3c5cc85b83
--- /dev/null
+++ b/recipes/zsh/zsh_4.1.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "The Zsh shell"
+SECTION = "base/shell"
+PRIORITY = "optional"
+DEPENDS = "ncurses libpcre"
+PR = "r2"
+LICENSE = "zsh"
+
+SRC_URI = "http://www.zsh.org/pub/old/zsh-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-curses-terminfo"
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cat aczsh.m4 > acinclude.m4
+ fi
+}
+
+#kill symlink
+do_install_append () {
+ mv ${D}${bindir}/zsh-${PV} ${D}${bindir}/zsh
+}