aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zsh
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-09 07:51:58 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-04 10:43:05 +0100
commitc3316cf01d65cb6a41d43a878846ecbafa283685 (patch)
tree6553aeb3e94dc27d8220fef7c6391482264a81b9 /recipes/zsh
parentd528b9fca92b803faff9f3e025cd0dc81fd74fea (diff)
downloadopenembedded-c3316cf01d65cb6a41d43a878846ecbafa283685.tar.gz
zsh: Add recipe for 4.3.10 (latest upstream).
* Checksum was already in OE.
Diffstat (limited to 'recipes/zsh')
-rw-r--r--recipes/zsh/zsh_4.3.10.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/zsh/zsh_4.3.10.bb b/recipes/zsh/zsh_4.3.10.bb
new file mode 100644
index 0000000000..3935e1f0cc
--- /dev/null
+++ b/recipes/zsh/zsh_4.3.10.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The Zsh shell"
+SECTION = "base/shell"
+PRIORITY = "optional"
+DEPENDS = "ncurses libpcre"
+PR = "r1"
+LICENSE = "zsh"
+
+SRC_URI = "http://www.zsh.org/pub/zsh-${PV}.tar.bz2 \
+"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+EXTRA_OECONF = "--with-term-lib="ncurses" --with-tcsetpgrp"
+PARALLEL_MAKE = ""
+
+#Kill symlink
+do_install_append () {
+ mv ${D}${bindir}/zsh-${PV} ${D}${bindir}/zsh
+}