aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zuc
diff options
context:
space:
mode:
authorMichal Hrusecky <Michal@Hrusecky.net>2009-05-30 14:14:54 +0100
committerPaul Eggleton <bluelightning@bluelightning.org>2009-05-30 14:14:54 +0100
commit02b2c0ff18a1135e82200f5d6834a6b04606e82e (patch)
tree2a8f61dfea397f5625cb9b53930135a0cad9fc57 /recipes/zuc
parente57d048f0895b369144de0b2f626964fb1e8e998 (diff)
downloadopenembedded-02b2c0ff18a1135e82200f5d6834a6b04606e82e.tar.gz
zuc: corrected iostream include to fix compilation
Signed-off-by: Michal Hrusecky <Michal@Hrusecky.net>
Diffstat (limited to 'recipes/zuc')
-rw-r--r--recipes/zuc/zuc/fixed-include.patch11
-rw-r--r--recipes/zuc/zuc_1.1.2ern.bb6
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes/zuc/zuc/fixed-include.patch b/recipes/zuc/zuc/fixed-include.patch
new file mode 100644
index 0000000000..fc4b80967a
--- /dev/null
+++ b/recipes/zuc/zuc/fixed-include.patch
@@ -0,0 +1,11 @@
+--- a/conv_matrix.cpp 2003-01-27 21:18:45.000000000 +0100
++++ b/conv_matrix.cpp 2009-05-30 00:57:23.311764092 +0200
+@@ -27,7 +27,7 @@
+ #include <qmap.h>
+ #include <qcombobox.h>
+ #include <qpopupmenu.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <stdlib.h>
+
+
diff --git a/recipes/zuc/zuc_1.1.2ern.bb b/recipes/zuc/zuc_1.1.2ern.bb
index 32c8f9848d..67a1aca4c5 100644
--- a/recipes/zuc/zuc_1.1.2ern.bb
+++ b/recipes/zuc/zuc_1.1.2ern.bb
@@ -5,10 +5,12 @@ LICENSE = "GPL"
APPTYPE = "binary"
APPNAME = "zuc"
APPDESKTOP = "${S}"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.linux-solutions.at/projects/zaurus/source/zuc_V${PV}.tar.gz \
- http://nick.kreucher.net/zuc/zuc_units"
+ http://nick.kreucher.net/zuc/zuc_units \
+ file://fixed-include.patch;patch=1"
+
S = "${WORKDIR}/zuc_V${PV}"
inherit opie