aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorJayen Ashar <jayen@cse.unsw.edu.au>2010-11-28 13:33:26 +1100
committerKhem Raj <raj.khem@gmail.com>2010-12-11 01:21:30 -0800
commit5cbe2d9cffc051abd8bc4cf56be3399163279060 (patch)
tree9bf805a10a6232cefca241bb053117d79b250cf2 /recipes
parent3ff643be4cf92865b26622838c5e06e88f8e8d47 (diff)
downloadopenembedded-5cbe2d9cffc051abd8bc4cf56be3399163279060.tar.gz
libQGLViewer: New program
* Starting with libQGLViewer 2.3.8 * libqglviewer (also known as libQGLViewer) is a free C++ library based on * Qt that enables the quick creation of OpenGL 3D viewers. It features a * powerful camera trackball and simple applications simply require an * implementation of the draw() function. It is a tool of choice for OpenGL * beginners and assignements. It provides screenshot saving, mouse * manipulated frames, stereo display, interpolated keyFrames, object * selection, and much more. It is fully customizable and easy to extend to * create complex applications, with a possible Qt GUI. Signed-off-by: Jayen Ashar <jayen@cse.unsw.edu.au> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libqglviewer/libqglviewer.inc20
-rw-r--r--recipes/libqglviewer/libqglviewer_2.3.8.bb3
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes/libqglviewer/libqglviewer.inc b/recipes/libqglviewer/libqglviewer.inc
new file mode 100644
index 0000000000..48ea5bcbb3
--- /dev/null
+++ b/recipes/libqglviewer/libqglviewer.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "an OpenGL 3D viewer library based on Qt4 - development files\
+libqglviewer (also known as libQGLViewer) is a free C++ library based on Qt that enables the quick creation of OpenGL 3D viewers. It features a powerful camera trackball and simple applications simply require an implementation of the draw() function. It is a tool of choice for OpenGL beginners and assignements. It provides screenshot saving, mouse manipulated frames, stereo display, interpolated keyFrames, object selection, and much more. It is fully customizable and easy to extend to create complex applications, with a possible Qt GUI."
+HOMEPAGE = "http://www.libqglviewer.com/"
+SECTION = "devel/libs" #seems to have more recipes than libs/devel
+LICENSE = "GPL" #You may use, distribute and copy the QGLViewer library under the terms of GNU General Public License version 2 or version 3, both of which are included in the LICENSE file.
+#DEPENDS = "" #requires qt4-x11-free with QT_CONFIG_FLAGS without -no-opengl
+
+INC_PR = "r0"
+
+SRC_URI = "http://www.libqglviewer.com/src/libQGLViewer-${PV}.tar.gz"
+
+S = "${WORKDIR}/libQGLViewer-${PV}/QGLViewer/"
+
+inherit qt4x11
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
+
+FILES_${PN}-dev += " ${libdir}/libQGLViewer.prl"
diff --git a/recipes/libqglviewer/libqglviewer_2.3.8.bb b/recipes/libqglviewer/libqglviewer_2.3.8.bb
new file mode 100644
index 0000000000..813f1a6af0
--- /dev/null
+++ b/recipes/libqglviewer/libqglviewer_2.3.8.bb
@@ -0,0 +1,3 @@
+require libqglviewer.inc
+
+PR = "${INC_PR}.0"