aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-12-10 12:51:38 -0700
committerTom Rini <tom_rini@mentor.com>2010-12-10 12:52:43 -0700
commit7ebbccee5eea68a1b7b5505aa8708e0eb547d135 (patch)
tree1d361f23d0815067f1e3b87f5508dbf72da5e376 /recipes
parentb9539b9e75aabbb6f2f99b35abaf6aa9e5e388fc (diff)
downloadopenembedded-7ebbccee5eea68a1b7b5505aa8708e0eb547d135.tar.gz
ust / userspace-rcu: Add recipes
Based on Esben Haabendal's recipes. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/lttng/userspace-rcu.inc13
-rw-r--r--recipes/lttng/userspace-rcu_0.4.6.bb3
-rw-r--r--recipes/lttng/ust.inc40
-rw-r--r--recipes/lttng/ust/ustd.init22
-rw-r--r--recipes/lttng/ust_0.8.bb3
5 files changed, 81 insertions, 0 deletions
diff --git a/recipes/lttng/userspace-rcu.inc b/recipes/lttng/userspace-rcu.inc
new file mode 100644
index 0000000000..592b598e58
--- /dev/null
+++ b/recipes/lttng/userspace-rcu.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Userspace RCU - liburcu is a userspace RCU (read-copy-update) library."
+SECTION = "libs"
+PRIORITY = "optional"
+PROVIDES = "liburcu"
+LICENSE = "LGPLv2.1"
+
+PR = "r1"
+
+SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
+
+S = "${WORKDIR}/userspace-rcu-${PV}"
+
+inherit autotools
diff --git a/recipes/lttng/userspace-rcu_0.4.6.bb b/recipes/lttng/userspace-rcu_0.4.6.bb
new file mode 100644
index 0000000000..281becb7e6
--- /dev/null
+++ b/recipes/lttng/userspace-rcu_0.4.6.bb
@@ -0,0 +1,3 @@
+require ${PN}.inc
+SRC_URI[md5sum] = "bd3403e7e5688d418bd0c778261c7782"
+SRC_URI[sha256sum] = "6ccf6c78bc8f825b94adf4976be77c194d98c2351d4a21e0cc7275e12a8a74d0"
diff --git a/recipes/lttng/ust.inc b/recipes/lttng/ust.inc
new file mode 100644
index 0000000000..26e4d4292b
--- /dev/null
+++ b/recipes/lttng/ust.inc
@@ -0,0 +1,40 @@
+DESCRIPTION = "LTTng Userspace Tracer (UST)"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPLv2 and LGPLv2.1"
+DEPENDS = "liburcu"
+
+PR = "r3"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ustd"
+INITSCRIPT_PARAMS = "defaults 99 0"
+
+UST_BASEDIR = "/tmp/ust"
+
+SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz \
+ file://ustd.init"
+
+S = "${WORKDIR}/ust-${PV}"
+
+inherit autotools
+
+do_compile_append () {
+ sed -e 's|^#!/bin/bash$|#!/bin/sh|' \
+ -e 's/^function \(.*() *{\)$/\1/' \
+ -e 's|^\(BASE_TRACE_DIR\)=.*|\1="${UST_BASEDIR}"|' \
+ -e 's/\(.*\)="$(<\(.*\))"/\1=`cat \2`/' \
+ -e 's/^\(DATESTRING\)=.*/\1="$(date +%Y%m%d%H%M%S)"/' \
+ -i ${S}/usttrace
+ sed -e 's|^\(TRACEDIR\)=.*|\1="${UST_BASEDIR}"|' \
+ -i ${WORKDIR}/ustd.init
+}
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/ustd.init ${D}${sysconfdir}/init.d/ustd
+}
+
+# Need the .so symlinks for preload to work
+FILES_${PN} += "${libdir}/libust*.so"
diff --git a/recipes/lttng/ust/ustd.init b/recipes/lttng/ust/ustd.init
new file mode 100644
index 0000000000..c23372a588
--- /dev/null
+++ b/recipes/lttng/ust/ustd.init
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+PIDFILE="/var/run/ustd.pid"
+TRACEDIR="/tmp/ust"
+
+case "$1" in
+
+ start)
+ mkdir -p $TRACEDIR
+ ustd -o $TRACEDIR -d --pidfile $PIDFILE
+ ;;
+
+ stop)
+ kill `cat $PIDFILE`
+ ;;
+
+ reload)
+ $0 stop
+ $0 start
+ ;;
+
+esac
diff --git a/recipes/lttng/ust_0.8.bb b/recipes/lttng/ust_0.8.bb
new file mode 100644
index 0000000000..16fc45b998
--- /dev/null
+++ b/recipes/lttng/ust_0.8.bb
@@ -0,0 +1,3 @@
+require ${PN}.inc
+SRC_URI[md5sum] = "333ff7c8fef92b31dff85789865bb791"
+SRC_URI[sha256sum] = "802398bc2c3ad5c80bd236d1ee24968f4da8a1401695e8dc15cb396ac836abb4"