aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-08 14:42:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-13 12:36:10 +0100
commit0328134214ad52d48e34f0080382f4f50f70db2c (patch)
treee232291a13c3977a81a878489172326eadfb0a65 /recipes
parentd6eb5340067ae02d3289ce6311d80a9752dbb8bc (diff)
downloadopenembedded-0328134214ad52d48e34f0080382f4f50f70db2c.tar.gz
task-boot: use DISTRO_UPDATE_ALTERNATIVES instead of update-alternatives directly
* Images built after 2009-12-08 9b641bbfed07c075ae5cbe84082a85f1ba703447 probably use opkg-native, but also ship with u-a-cworth Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/tasks/task-boot.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes/tasks/task-boot.bb b/recipes/tasks/task-boot.bb
index 04c55357a8..45d50ef672 100644
--- a/recipes/tasks/task-boot.bb
+++ b/recipes/tasks/task-boot.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Basic task to get a device booting"
-PR = "r51"
+PR = "r52"
inherit task
@@ -13,6 +13,12 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+# update-alternatives script installed in rootfs needs to be the same as
+# u-a script used for building image which is defined with
+# PREFERRED_PROVIDER_virtual/update-alternatives-native
+
+DISTRO_UPDATE_ALTERNATIVES ?= "${PREFERRED_PROVIDER_virtual/update-alternatives}"
+
# Make sure we build the kernel
DEPENDS = "virtual/kernel"
@@ -26,7 +32,7 @@ RDEPENDS_task-boot = "\
${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
modutils-initscripts \
netbase \
- update-alternatives \
+ ${DISTRO_UPDATE_ALTERNATIVES} \
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
"