aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-01-27 07:58:36 +0000
committerPhilip Balister <philip@balister.org>2010-01-27 14:24:08 -0500
commit16535dde428e8e9b87dfecf3888ed54cd4aab030 (patch)
tree51a44311c725dff4382dd56e4704f49151e3326d /recipes
parent96b3f7e82dafa658f337b3b1433eba8139ca566e (diff)
downloadopenembedded-16535dde428e8e9b87dfecf3888ed54cd4aab030.tar.gz
udev: get rid of 'timestamp in the future' tar messages
This patch tries to get rid of spew of the useless tar messages durring boot process on machines without RTC, such as the Beagleboard. Example: Please wait: booting... Starting udev tar: dev/.udev/uevent_seqnum: time stamp 1970-01-01 01:00:21 is 14.122497521 s in the future tar: dev/.udev/rules.d: time stamp 1970-01-01 01:00:07 is 0.119201623 s in the future tar: dev/.udev/db/\x2fdevices\x2fvirtual\x2fblock\x2fram9: time stamp 1970-01-01 01:00:22 is 15.118713341 s in the future [ more then 100 similar lines cutted off] Signed-off-by: Petr Štetiar <ynezz@true.cz> Acked-by: Chris Larson <clarson@mvista.com> Signed-off-by: Philip Balister <philip@balister.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/udev/udev-141/init2
-rw-r--r--recipes/udev/udev_141.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/udev/udev-141/init b/recipes/udev/udev-141/init
index 24ca9d874d..66705e6767 100644
--- a/recipes/udev/udev-141/init
+++ b/recipes/udev/udev-141/init
@@ -44,7 +44,7 @@ if [ "$DEVCACHE" != "" ]; then
cmp -s /tmp/uname /etc/udev/saved.uname && \
cmp -s /tmp/cmdline /etc/udev/saved.cmdline && \
cmp -s /tmp/atags /etc/udev/saved.atags; then
- (cd /; tar xf $DEVCACHE)
+ (cd /; tar xf $DEVCACHE > /dev/null 2>&1)
not_first_boot=1
fi
fi
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index df5e346c4d..d1fee30d18 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r20"
+PR = "r21"
# needed for init.d script
RDEPENDS_${PN} += "udev-utils"