aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-23 08:55:22 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-23 08:55:22 +0200
commit1a2d098a0beab058850803ea696ade5b692e8d42 (patch)
treeec5496c1820982493aab72d5d3e9f37e6b89cbd0 /recipes
parent05386b063841e29f03ec301c111250391cdc52b4 (diff)
downloadopenembedded-1a2d098a0beab058850803ea696ade5b692e8d42.tar.gz
linux-omap-pm 2.6.29: fix beagleboard audio
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-omap-pm-2.6.29/fix-audio-capture.patch18
-rw-r--r--recipes/linux/linux-omap-pm_2.6.29.bb4
2 files changed, 20 insertions, 2 deletions
diff --git a/recipes/linux/linux-omap-pm-2.6.29/fix-audio-capture.patch b/recipes/linux/linux-omap-pm-2.6.29/fix-audio-capture.patch
index 7470a7cacc..8aaac57b5f 100644
--- a/recipes/linux/linux-omap-pm-2.6.29/fix-audio-capture.patch
+++ b/recipes/linux/linux-omap-pm-2.6.29/fix-audio-capture.patch
@@ -31,3 +31,21 @@ index ee2f0d3..8b4aafb 100644
config SND_OMAP_SOC_OSK5912
tristate "SoC Audio support for omap osk5912"
depends on SND_OMAP_SOC && MACH_OMAP_OSK
+--- /tmp/Makefile 2009-06-23 08:37:40.000000000 +0200
++++ git/sound/soc/omap/Makefile 2009-06-23 08:38:38.000000000 +0200
+@@ -7,6 +7,7 @@
+
+ # OMAP Machine Support
+ snd-soc-n810-objs := n810.o
++snd-soc-omap3beagle-objs := omap3beagle.o
+ snd-soc-osk5912-objs := osk5912.o
+ snd-soc-overo-objs := overo.o
+ snd-soc-omap2evm-objs := omap2evm.o
+@@ -14,6 +15,7 @@
+ snd-soc-omap3pandora-objs := omap3pandora.o
+
+ obj-$(CONFIG_SND_OMAP_SOC_N810) += snd-soc-n810.o
++obj-$(CONFIG_SND_OMAP_SOC_OMAP3_BEAGLE) += snd-soc-omap3beagle.o
+ obj-$(CONFIG_SND_OMAP_SOC_OSK5912) += snd-soc-osk5912.o
+ obj-$(CONFIG_SND_OMAP_SOC_OVERO) += snd-soc-overo.o
+ obj-$(CONFIG_MACH_OMAP2EVM) += snd-soc-omap2evm.o
diff --git a/recipes/linux/linux-omap-pm_2.6.29.bb b/recipes/linux/linux-omap-pm_2.6.29.bb
index 80303774f3..5eebc1e8fb 100644
--- a/recipes/linux/linux-omap-pm_2.6.29.bb
+++ b/recipes/linux/linux-omap-pm_2.6.29.bb
@@ -5,10 +5,10 @@ KERNEL_IMAGETYPE = "uImage"
COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo"
-SRCREV = "cbfc461bd5c4d0aff8501dd82db18146a22f49cf"
+SRCREV = "9c133058b929e738e6f28cb99e99c7fb5b35c59a"
PV = "2.6.29"
-MACHINE_KERNEL_PR_append = "-pm1+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "-pm2+gitr${SRCREV}"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm-2.6.29 \
file://defconfig"