aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-04 19:44:53 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-04 19:44:53 +0100
commit1c3976fffbaba8d66915b30e63313a6228688d0d (patch)
treed334296bec49232dad72b8949edbd2272de5019a /recipes
parenta66595deff9fa3d23f605da076f3734d7f12e7c0 (diff)
downloadopenembedded-1c3976fffbaba8d66915b30e63313a6228688d0d.tar.gz
libnl2: bump git revision and fix pc file so that it actually links to the support libraries
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libnl/files/fix-pc-file.patch11
-rw-r--r--recipes/libnl/libnl2_git.bb11
2 files changed, 17 insertions, 5 deletions
diff --git a/recipes/libnl/files/fix-pc-file.patch b/recipes/libnl/files/fix-pc-file.patch
new file mode 100644
index 0000000000..77f3e88562
--- /dev/null
+++ b/recipes/libnl/files/fix-pc-file.patch
@@ -0,0 +1,11 @@
+Index: git/libnl-2.0.pc.in
+===================================================================
+--- git.orig/libnl-2.0.pc.in
++++ git/libnl-2.0.pc.in
+@@ -6,5 +6,5 @@
+ Name: libnl
+ Description: Convenience library for netlink sockets
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -lnl
++Libs: -L${libdir} -lnl -lnl-genl -lnl-nf -lnl-route
+ Cflags: -I${includedir}
diff --git a/recipes/libnl/libnl2_git.bb b/recipes/libnl/libnl2_git.bb
index 9e2c3d7ecc..ebea78441b 100644
--- a/recipes/libnl/libnl2_git.bb
+++ b/recipes/libnl/libnl2_git.bb
@@ -2,16 +2,17 @@ DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
SECTION = "libs/network"
LICENSE = "LGPL"
HOMEPAGE = "http://people.suug.ch/~tgr/libnl"
-PV = "1.0+gitr${SRCREV}"
-PR = "r1"
+PV = "1.9+gitr${SRCREV}"
+PR = "r0"
inherit autotools
-#CFLAGS += '-DVLAN_FLAG_REORDER_HDR=1'
-
includedir = ${prefix}/include/libnl2
-SRC_URI = "git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git"
+SRC_URI = "\
+ git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git \
+ file://fix-pc-file.patch;patch=1 \
+"
S = "${WORKDIR}/git"
PACKAGES =+ "${PN}-route ${PN}-nf ${PN}-genl"