aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorValery Febvre <vfebvre@easter-eggs.com>2010-01-28 13:00:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-28 23:34:18 +0100
commit50a6a82329d668a0b64fb883695d384985a8fafa (patch)
tree8abb857cb828f754f8554f492de4eb45929556ca /recipes
parenta5a0c77301d35938a80de1b4c64439c746732521 (diff)
downloadopenembedded-50a6a82329d668a0b64fb883695d384985a8fafa.tar.gz
podboy: new recipe for another elementary based podcast app
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/openmoko-3rdparty/podboy_svn.bb24
-rw-r--r--recipes/tasks/task-shr-feed.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/podboy_svn.bb b/recipes/openmoko-3rdparty/podboy_svn.bb
new file mode 100644
index 0000000000..b7a7ad99b5
--- /dev/null
+++ b/recipes/openmoko-3rdparty/podboy_svn.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A podcast aggregator/player"
+HOMEPAGE = "http://code.google.com/p/podboy/"
+LICENSE = "GPLv3"
+AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+
+SRCREV = "100"
+PV = "1.3.1+svnr${SRCPV}"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "svn://podboy.googlecode.com/svn;module=trunk;proto=http"
+S = "${WORKDIR}/trunk"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}/podboy ${datadir}/applications/podboy.desktop ${datadir}/pixmaps/podboy.png"
+
+RDEPENDS += "python-compression python-elementary python-gst python-html python-netclient python-netserver python-sqlite3 python-subprocess gst-plugin-alsa gst-plugin-audioconvert gst-plugin-audioresample gst-plugin-bluez gst-plugin-mad gst-plugin-ogg gst-plugin-volume gst-plugin-vorbis"
+
+do_compile_prepend() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc ${S}/data/podboy.edc
+}
diff --git a/recipes/tasks/task-shr-feed.bb b/recipes/tasks/task-shr-feed.bb
index edd78eb57f..f6106d1517 100644
--- a/recipes/tasks/task-shr-feed.bb
+++ b/recipes/tasks/task-shr-feed.bb
@@ -270,4 +270,5 @@ RDEPENDS_${PN} += "\
rtmom \
ventura \
emtooth \
+ podboy \
"