aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-01 22:42:07 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-01 22:42:07 +0200
commitc874adcc0ab3a133207efe4dd1bd1ac71a762c46 (patch)
tree4fa3497c51900a005b5cd4bb8acc504a7c71200d /recipes
parent8aeac1fd6f0802e4f36e36b5fc58ce56371cf5b6 (diff)
downloadopenembedded-c874adcc0ab3a133207efe4dd1bd1ac71a762c46.tar.gz
fennec: update to latest tip
* fix up buildsystem contamination bug in firefox.inc while I'm at it as well
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mozilla/fennec_hg.bb12
-rw-r--r--recipes/mozilla/firefox.inc7
2 files changed, 13 insertions, 6 deletions
diff --git a/recipes/mozilla/fennec_hg.bb b/recipes/mozilla/fennec_hg.bb
index 94996134fa..ef4cedd70b 100644
--- a/recipes/mozilla/fennec_hg.bb
+++ b/recipes/mozilla/fennec_hg.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Mozilla Mobile browser"
-PV = "0.9+1.0b2pre"
-MOZPV = "1.0b2pre"
-PR = "r5"
+PV = "0.9+1.0b4pre"
+MOZPV = "1.0b4pre"
+PR = "r7"
PE = "1"
-SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=8c9a6d851018 \
- hg://hg.mozilla.org/;module=mobile-browser;rev=c24b8b4ade53 \
+SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=37acc871cb55 \
+ hg://hg.mozilla.org/;module=mobile-browser;rev=c725e5e30b9d \
file://jsautocfg.h \
file://jsautocfg-dontoverwrite.patch;patch=1 \
file://use-native-bpp.patch;patch=1 \
@@ -20,7 +20,7 @@ require firefox.inc
DEPENDS += "libnotify autoconf213-native cairo alsa-lib sqlite3"
PARALLEL_MAKE = ""
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"
diff --git a/recipes/mozilla/firefox.inc b/recipes/mozilla/firefox.inc
index 1be9c4da8f..8526a8d151 100644
--- a/recipes/mozilla/firefox.inc
+++ b/recipes/mozilla/firefox.inc
@@ -30,6 +30,13 @@ FILES_${PN}-dbg += " ${libdir}/${PN}-*/.debug \
${bindir}/.debug \
"
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+
+# Due to sysroot we need to sed out references to the target staging when building the native version of xpidl
+# Symptons of the failure include "gthread.h:344: error: size of array 'type name' is negative"
+export HOST_LIBIDL_CFLAGS = "`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}:${STAGING_DIR_NATIVE}:g`"
+
+
do_install() {
oe_runmake DESTDIR="${D}" destdir="${D}" install
install -d ${D}${datadir}/applications