aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-28 16:31:58 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-28 16:31:58 -0700
commitd24436424f2a706d70d2ef2cb8906cce6526698c (patch)
treeaf7bf6064b4e30527ed1898918e58c78bed60751 /recipes
parentb88a3344fcae52f4bb878c86cec273612488f52c (diff)
parent58367f3a79ba547545e762797a06875e2751e58e (diff)
downloadopenembedded-d24436424f2a706d70d2ef2cb8906cce6526698c.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/erlang/erlang-native_R13B01.bb5
-rw-r--r--recipes/erlang/erlang_R13B01.bb5
-rw-r--r--recipes/matchbox-session/matchbox-session.bb14
-rw-r--r--recipes/xorg-driver/xf86-video-vesa_2.2.0.bb3
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/vortex86sx/xorg.conf13
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch27
-rw-r--r--recipes/xserver-common/xserver-common_1.30.bb3
8 files changed, 67 insertions, 5 deletions
diff --git a/recipes/erlang/erlang-native_R13B01.bb b/recipes/erlang/erlang-native_R13B01.bb
index bc0e343b42..0e69dcee83 100644
--- a/recipes/erlang/erlang-native_R13B01.bb
+++ b/recipes/erlang/erlang-native_R13B01.bb
@@ -2,13 +2,16 @@ include erlang.inc
inherit native
+PR = "r1"
+
# EXTRA_OEMAKE = 'OTP_SMALL_BUILD=true'
EXTRA_OECONF = '--without-ssl'
do_configure() {
TARGET=${HOST_SYS} \
ac_cv_prog_javac_ver_1_2=no \
- oe_runconf
+ ac_cv_prog_javac_ver_1_5=no \
+ oe_runconf
}
do_compile_prepend() {
diff --git a/recipes/erlang/erlang_R13B01.bb b/recipes/erlang/erlang_R13B01.bb
index 33ecfc7564..eda4db67a4 100644
--- a/recipes/erlang/erlang_R13B01.bb
+++ b/recipes/erlang/erlang_R13B01.bb
@@ -1,6 +1,8 @@
include erlang.inc
DEPENDS += "erlang-native openssl"
+PR = "r1"
+
SRC_URI += "\
file://erts-emulator-Makefile.in.patch;patch=1 \
file://erts-etc-unix-Install.src.patch;patch=1 \
@@ -29,7 +31,8 @@ do_configure() {
. ${CONFIG_SITE}
ac_cv_prog_javac_ver_1_2=no \
- SHLIB_LD='${CC}' \
+ ac_cv_prog_javac_ver_1_5=no \
+ SHLIB_LD='${CC}' \
oe_runconf
sed -i -e 's|$(ERL_TOP)/bin/dialyzer|${NATIVE_BIN}/dialyzer --output_plt $@ -pa $(ERL_TOP)/lib/kernel/ebin -pa $(ERL_TOP)/lib/stdlib/ebin|' lib/dialyzer/src/Makefile
diff --git a/recipes/matchbox-session/matchbox-session.bb b/recipes/matchbox-session/matchbox-session.bb
new file mode 100644
index 0000000000..c9014f9000
--- /dev/null
+++ b/recipes/matchbox-session/matchbox-session.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Matchbox session support"
+RDEPENDS = "matchbox-common"
+# they do the same in other way
+RCONFLICTS = "gpe-session-scripts"
+
+do_install() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ ln -sf ${bindir}/matchbox-session ${D}${sysconfdir}/X11/Xsession.d/90matchbox-session
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${sysconfdir}"
diff --git a/recipes/xorg-driver/xf86-video-vesa_2.2.0.bb b/recipes/xorg-driver/xf86-video-vesa_2.2.0.bb
index bd2f7cf7c1..5ec423a918 100644
--- a/recipes/xorg-driver/xf86-video-vesa_2.2.0.bb
+++ b/recipes/xorg-driver/xf86-video-vesa_2.2.0.bb
@@ -6,4 +6,5 @@ SRC_URI += "file://fix-includepath.patch;patch=1 \
#DESCRIPTION = ""
-#DEPENDS += " "
+RDEPENDS += "xserver-xorg-module-int10 "
+PR = "r1"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/vortex86sx/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/vortex86sx/xorg.conf
new file mode 100644
index 0000000000..0f03faf33d
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/vortex86sx/xorg.conf
@@ -0,0 +1,13 @@
+Section "Device"
+ Identifier "Card0"
+ Driver "vesa"
+EndSection
+
+# SIS driver is proper one for this device but fails with misc errors.
+#Section "Device"
+# Identifier "Card0"
+# Driver "sis"
+#
+# Disable MMX/SSE tests
+# Option "BenchmarkMemCpy" "off"
+#EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index d288091ea1..783d1b09cc 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r7"
+PR = "r8"
SRC_URI = "file://xorg.conf"
diff --git a/recipes/xserver-common/xserver-common-1.30/0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch b/recipes/xserver-common/xserver-common-1.30/0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch
new file mode 100644
index 0000000000..e80cbac71e
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch
@@ -0,0 +1,27 @@
+From 0ea66d0827131952dc1069f1ea3cb317b831df55 Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <hrw@koansoftware.com>
+Date: Fri, 28 Aug 2009 18:47:55 +0200
+Subject: [PATCH 1/1] Xserver: provide -screen argument only for non-X.org servers
+
+---
+ X11/Xserver | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/X11/Xserver b/X11/Xserver
+index 3d93a0a..583cd0d 100755
+--- a/X11/Xserver
++++ b/X11/Xserver
+@@ -179,7 +179,9 @@ else
+ # It is a device we do not know about, in which case we force
+ # kdrive to use the current framebuffer geometry -- otherwise
+ # it will default to trying to achieve 1024x768
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ if [ "$XSERVER" != "Xorg" ] ; then
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ fi
+ fi
+ esac
+ fi
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common_1.30.bb b/recipes/xserver-common/xserver-common_1.30.bb
index 3f3e7f889f..edb3464338 100644
--- a/recipes/xserver-common/xserver-common_1.30.bb
+++ b/recipes/xserver-common/xserver-common_1.30.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
-PR = "r2"
+PR = "r3"
PACKAGE_ARCH = "all"
DEFAULT_PREFERENCE = "-1"
@@ -17,6 +17,7 @@ file://0019-keymap-fixed-machine-names.patch;patch=1 \
file://0020-keymap-fixed-machine-names-again.patch;patch=1 \
file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;patch=1 \
file://0022-xserver-fix-syntax-error.patch;patch=1 \
+file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch;patch=1 \
"
do_install_append() {