aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-02-24 17:16:59 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:19 +0200
commitd472e932b63cdff4cc97958b76e83028d8ec5199 (patch)
treec33f624f9d87fd7db196bae4f34de6432723fcde /recipes
parent5501f93ce7a356dd5fb4ab7382e6bbd7585a42a5 (diff)
downloadopenembedded-d472e932b63cdff4cc97958b76e83028d8ec5199.tar.gz
freondemo: update to latest git, add ipcsink
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ti/freondemo_git.bb8
-rwxr-xr-xrecipes/ti/gst-ipcsink_git.bb25
-rw-r--r--recipes/ti/gstd_git.bb6
3 files changed, 32 insertions, 7 deletions
diff --git a/recipes/ti/freondemo_git.bb b/recipes/ti/freondemo_git.bb
index b85145b950..ae943a7149 100644
--- a/recipes/ti/freondemo_git.bb
+++ b/recipes/ti/freondemo_git.bb
@@ -6,13 +6,13 @@ SECTION = "multimedia"
PRIORITY = "optional"
DEPENDS = "dbus gstd"
-RDEPENDS_${PN} = "gstd alsa-utils-amixer"
-RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
+RDEPENDS_${PN} = "gstd alsa-utils-amixer gst-ipcsink"
+RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib gstreamer-ti"
-SRCREV = "b5c93e9d017d14c945c30b0cb47fb00cbf41b12b"
+SRCREV = "19c4e201aa978d2b40793b9fa76cc4ddbff50016"
PV = "1.0"
-PR = "r6"
+PR = "r7"
PR_append = "+gitr${SRCREV}"
SRC_URI = "git://freondemo.git.sourceforge.net/gitroot/freondemo/freondemo;protocol=git \
diff --git a/recipes/ti/gst-ipcsink_git.bb b/recipes/ti/gst-ipcsink_git.bb
new file mode 100755
index 0000000000..e8a184ccd6
--- /dev/null
+++ b/recipes/ti/gst-ipcsink_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "gst-ipcsink: custom gstreamer element for IPC video sink"
+HOMEPAGE = "http://sourceforge.net/projects/freondemo"
+MAINTAINER = "http://sourceforge.net/projects/freondemo"
+LICENSE = "BSD"
+SECTION = "multimedia"
+PRIORITY = "optional"
+
+DEPENDS = "gstreamer gst-plugins-base"
+
+SRCREV=7e38d82d1207bb75f235f5643c4c2d15591e9b3c
+
+PV = "1.0"
+PR = "r0"
+PR_append= "+gitr${SRCREV}"
+
+inherit autotools
+
+SRC_URI = "git://freondemo.git.sourceforge.net/gitroot/freondemo/gst-ipcsink;protocol=git"
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so ${sysconfdir}"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.la"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+
+
diff --git a/recipes/ti/gstd_git.bb b/recipes/ti/gstd_git.bb
index 003705c10b..143b4b60d5 100644
--- a/recipes/ti/gstd_git.bb
+++ b/recipes/ti/gstd_git.bb
@@ -8,13 +8,13 @@ PRIORITY = "optional"
DEPENDS = "dbus dbus-glib gstreamer"
RDEPENDS = "gst-plugins-base"
-SRCREV = "525cecebdb8f59157a69ec2f6cfaa46800b20b79"
+SRCREV = "7ba92f30db6f72531554a7b0335e757182c60020"
PV = "1.0"
-PR = "r6"
+PR = "r7"
PR_append = "+gitr${SRCREV}"
-SRC_URI = "git://gstd.git.sourceforge.net/gitroot/gstd/harrier;protocol=git \
+SRC_URI = "git://gstd.git.sourceforge.net/gitroot/gstd/gstd;protocol=git \
"
S = "${WORKDIR}/git"