aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-31 12:51:01 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-31 12:51:01 +0200
commitee3347eea156941ba4847a3cfa784cd3d3068019 (patch)
tree1dc018d55c2d54093a12919af8940606f3d5b336 /recipes
parent9545699b447f4d548cca7bb1f54dc1c01dd3fe4a (diff)
downloadopenembedded-ee3347eea156941ba4847a3cfa784cd3d3068019.tar.gz
u-boot git: add patch to power on USB on beagleboard xM rev A
Diffstat (limited to 'recipes')
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0038-Added-configurations-for-xM-Rev-A-board.patch29
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0038-Added-configurations-for-xM-Rev-A-board.patch b/recipes/u-boot/u-boot-git/beagleboard/0038-Added-configurations-for-xM-Rev-A-board.patch
new file mode 100644
index 0000000000..4cfcfe15b1
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0038-Added-configurations-for-xM-Rev-A-board.patch
@@ -0,0 +1,29 @@
+From 9a5d5518c3d3844cc49cf2d9ef5aeabca1e87c30 Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jkridner@beagleboard.org>
+Date: Wed, 5 May 2010 14:53:49 -0500
+Subject: [PATCH 38/38] Added configurations for xM Rev A board
+
+This defaults to "on" condition for USB and DVI. May want to revise for
+power savings.
+---
+ board/ti/beagle/beagle.h | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
+index 7774855..cb7fd1c 100644
+--- a/board/ti/beagle/beagle.h
++++ b/board/ti/beagle/beagle.h
+@@ -389,6 +389,10 @@ const omap3_sysinfo sysinfo = {
+ MUX_VAL(CP(UART2_TX), (IDIS | PTD | DIS | M0)) /*UART2_TX*/
+
+ #define MUX_BEAGLE_XM() \
++ MUX_VAL(CP(GPMC_NCS5), (IDIS | PTD | EN | M4)) /*GPIO_56 - USB HUB reset*/\
++ MUX_VAL(CP(GPMC_WAIT0), (IDIS | PTU | EN | M4)) /*GPIO_63 - P8 USB HUB nreset*/\
++ MUX_VAL(CP(MMC1_DAT7), (IDIS | PTU | EN | M4)) /*GPIO_129 - DVI enable*/\
++ MUX_VAL(CP(HDQ_SIO), (IDIS | PTU | EN | M4)) /*GPIO_170 - P8 DVI enable*/\
+ MUX_VAL(CP(MCBSP3_DX), (IEN | PTD | DIS | M4)) /*GPIO_140*/\
+ MUX_VAL(CP(MCBSP3_DR), (IEN | PTD | DIS | M4)) /*GPIO_142*/\
+ MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTD | DIS | M4)) /*GPIO_141*/\
+--
+1.6.6.1
+
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 03c0661aad..90ca78d386 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r50"
+PR ="r51"
FILESPATHPKG =. "u-boot-git:"
@@ -56,6 +56,7 @@ SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
file://0035-OMAP3-Beagle-set-mpurate-to-1000-for-xM.patch \
file://0036-OMAP3-Beagle-decrease-bootdelay-to-3-use-VGA-for-def.patch \
file://0037-OMAP3-beagle-pass-expansionboard-name-in-bootargs.patch \
+ file://0038-Added-configurations-for-xM-Rev-A-board.patch \
file://fw_env.config \
"
SRCREV_beagleboard = "ca6e1c136ddb720c3bb2cc043b99f7f06bc46c55"