aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2010-05-28 06:49:41 +0000
committerEric Bénard <eric@eukrea.com>2010-10-04 22:57:37 +0200
commit51f101e880c388e0f7bdf876930e1f3749b2dae0 (patch)
tree05f22989b372b1c3d7eb4d1d4ccd7fd979a87826 /recipes
parentb0bcd6021f3f03a089220ac68fc9156dec894aa1 (diff)
downloadopenembedded-51f101e880c388e0f7bdf876930e1f3749b2dae0.tar.gz
ttf-droid: new recipe
Add recipe for Droid fonts (specifically developed by Ascender for Google's Android platform). Since there's no canonical tarball URL for these fonts, we fetch them directly from Android git repo. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ttf-fonts/ttf-droid_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/ttf-fonts/ttf-droid_git.bb b/recipes/ttf-fonts/ttf-droid_git.bb
new file mode 100644
index 0000000000..3fa04abf5d
--- /dev/null
+++ b/recipes/ttf-fonts/ttf-droid_git.bb
@@ -0,0 +1,28 @@
+require ttf.inc
+
+DESCRIPTION = "Droid fonts - TTF Edition"
+HOMEPAGE = "http://www.droidfonts.com/"
+LICENSE = "Apache-2.0"
+PR = "r0"
+# git magic below - SRCREV is an ID of /data/fonts subtree
+# (so we don't need to fetch full platform/frameworks/base.git)
+SRCREV = "31f255e44e618ff3b923f332e8fcb83403fd39f5"
+PV = "0.0+${PR}+gitr${SRCREV}"
+
+SRC_URI = "git://android.git.kernel.org/platform/frameworks/base.git;protocol=git;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_install_prepend() {
+ rm ${S}/Ahem.ttf # we're not packaging it
+}
+
+PACKAGES = "${PN}-dbg ttf-droid-sans ttf-droid-sans-mono \
+ ttf-droid-sans-fallback ttf-droid-sans-japanese ttf-droid-serif"
+RRECOMMENDS_${PN}-dbg = ""
+
+FILES_ttf-droid-sans = "${datadir}/fonts/truetype/DroidSans.ttf ${datadir}/fonts/truetype/DroidSans-Bold.ttf"
+FILES_ttf-droid-sans-mono = "${datadir}/fonts/truetype/DroidSansMono.ttf"
+FILES_ttf-droid-sans-fallback = "${datadir}/fonts/truetype/DroidSansFallback.ttf"
+FILES_ttf-droid-sans-japanese = "${datadir}/fonts/truetype/DroidSansJapanese.ttf"
+FILES_ttf-droid-serif = "${datadir}/fonts/truetype/DroidSerif*.ttf"