aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-01 13:41:31 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-01 14:04:14 +0200
commit52f02af4fa453ea8c071cccb342e6056383614b7 (patch)
treea16e03e9d4ab4a21072b8e85338bea7fd616afe9 /recipes
parent1664469b58f5d636d101e3b58a0445ba11758603 (diff)
downloadopenembedded-52f02af4fa453ea8c071cccb342e6056383614b7.tar.gz
gnome-settings-daemon: add 2.30.0, convert to new style staging
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnome/gnome-settings-daemon_2.28.0.bb5
-rw-r--r--recipes/gnome/gnome-settings-daemon_2.30.0.bb27
2 files changed, 29 insertions, 3 deletions
diff --git a/recipes/gnome/gnome-settings-daemon_2.28.0.bb b/recipes/gnome/gnome-settings-daemon_2.28.0.bb
index 43585f3425..cce5df981e 100644
--- a/recipes/gnome/gnome-settings-daemon_2.28.0.bb
+++ b/recipes/gnome/gnome-settings-daemon_2.28.0.bb
@@ -4,6 +4,8 @@ LICENSE = "GPL"
DEPENDS = "libxklavier libgnomekbd libgnomeui gnome-desktop gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl"
+PR = "r1"
+
inherit gnome
LDFLAGS += "-lgthread-2.0"
@@ -22,7 +24,4 @@ do_configure_prepend () {
sed -i 's:$CPPFLAGS -I$includedir:$CPPFLAGS:' ${S}/configure.ac
}
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/gnome/gnome-settings-daemon_2.30.0.bb b/recipes/gnome/gnome-settings-daemon_2.30.0.bb
new file mode 100644
index 0000000000..62547af732
--- /dev/null
+++ b/recipes/gnome/gnome-settings-daemon_2.30.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNOME settings daemon"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+
+DEPENDS = "libxklavier libgnomekbd libgnomeui gnome-desktop gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "a21485e7deca785f2ffb8ded58c4ae6a"
+SRC_URI[archive.sha256sum] = "cb759f2aa403ad10f7b0a196c523fa0b3842cf4432b26a4b308ed1e5bf67e6aa"
+
+LDFLAGS += "-lgthread-2.0"
+
+FILES_${PN} += "${libdir}/gnome-settings-daemon-2.0/*.so \
+ ${libdir}/gnome-settings-daemon-2.0/*plugin \
+ ${datadir}/dbus-1/ \
+ ${datadir}/gnome-control-center \
+ ${datadir}/icons \
+ "
+
+FILES_${PN}-dbg += "${libdir}/gnome-settings-daemon-2.0/.debug"
+FILES_${PN}-dev += "${libdir}/gnome-settings-daemon-2.0/*.a ${libdir}/gnome-settings-daemon-2.0/*.la"
+
+do_configure_prepend () {
+ sed -i 's:$CPPFLAGS -I$includedir:$CPPFLAGS:' ${S}/configure.ac
+}
+