aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-17 13:06:09 -0700
committerTom Rini <trini@embeddedalley.com>2009-04-17 14:38:50 -0700
commitad507618ca0f888b45763c286dae033873cac468 (patch)
tree154539e9945c0fe4b8f9518a980f10ba5456a170 /recipes
parent669c8f650372b9208a036174fc137f23d791d428 (diff)
downloadopenembedded-ad507618ca0f888b45763c286dae033873cac468.tar.gz
mingw-gcc, mingw-runtime, mingw-w32api: Fix DEFAULT_PREFERENCES to be correct
We want a default of -1 (not 0) and 1 for "mingw32" so that the default list of overrides will catch and use them.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb4
-rw-r--r--recipes/mingw/mingw-runtime.inc4
-rw-r--r--recipes/mingw/mingw-w32api.inc4
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb b/recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb
index 22f91703ee..fd45e9f022 100644
--- a/recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb
+++ b/recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb
@@ -4,8 +4,8 @@ HOMEPAGE = "http://www.mingw.org/"
SECTION = "devel"
LICENSE = "GPL"
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
inherit autotools gettext
diff --git a/recipes/mingw/mingw-runtime.inc b/recipes/mingw/mingw-runtime.inc
index d984911fff..5820e9914f 100644
--- a/recipes/mingw/mingw-runtime.inc
+++ b/recipes/mingw/mingw-runtime.inc
@@ -5,8 +5,8 @@ DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial mingw-w32api"
PROVIDES = "virtual/${TARGET_PREFIX}libc virtual/${TARGET_PREFIX}libc-for-gcc"
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
PACKAGES = ""
diff --git a/recipes/mingw/mingw-w32api.inc b/recipes/mingw/mingw-w32api.inc
index ecb1cd290a..ac2ede9945 100644
--- a/recipes/mingw/mingw-w32api.inc
+++ b/recipes/mingw/mingw-w32api.inc
@@ -5,8 +5,8 @@ DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial"
PROVIDES = "mingw-w32api"
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
PACKAGES = ""