aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-01 17:00:49 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-01 17:00:49 +0200
commit05795ae1c61180f0fc7ac474c5f61640b1453a83 (patch)
tree5e17c6c6d239eefef87489efd1cac566423887e5 /recipes
parentbfcf9c705f750f366705c17e8e1305761a548b09 (diff)
downloadopenembedded-05795ae1c61180f0fc7ac474c5f61640b1453a83.tar.gz
clutter 0.9: add from poky
Diffstat (limited to 'recipes')
-rw-r--r--recipes/clutter/clutter-0.9_git.bb12
-rw-r--r--recipes/clutter/files/enable_tests.patch32
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/clutter/clutter-0.9_git.bb b/recipes/clutter/clutter-0.9_git.bb
new file mode 100644
index 0000000000..a8b8a36318
--- /dev/null
+++ b/recipes/clutter/clutter-0.9_git.bb
@@ -0,0 +1,12 @@
+require clutter.inc
+
+SRCREV = "35191f09ef0fa8fad6f386513dcd691ab6b6746f"
+PV = "0.9.2"
+PR_append = "+git${SRCREV}"
+
+SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=master \
+ file://enable_tests.patch;patch=1 "
+S = "${WORKDIR}/git"
+
+BASE_CONF += "--disable-introspection"
+
diff --git a/recipes/clutter/files/enable_tests.patch b/recipes/clutter/files/enable_tests.patch
new file mode 100644
index 0000000000..953edf6bbc
--- /dev/null
+++ b/recipes/clutter/files/enable_tests.patch
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am | 7 ++++++-
+ tests/test-actors.c | 2 +-
+ tests/test-text.c | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am 2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
+
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+
+ test_interactive_SOURCES = \
+ test-main.c \
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c 2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c 2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+ oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+ oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+
+- real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++ real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+ if (real_hand == NULL)
+ {
+ g_error ("image load failed: %s", error->message);