aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2010-09-24 13:28:17 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-09-24 13:32:51 +0200
commit0e3642cacf17a8b8073cf7caaa88279d1b6f945f (patch)
tree34b95c3057c7a7ac5e06ba6d356985a6c5ce7f54 /recipes
parent14de19142d3ac83f4c6bcf71654c36df305f856b (diff)
downloadopenembedded-0e3642cacf17a8b8073cf7caaa88279d1b6f945f.tar.gz
gcc: added 2010.09 Linaro release of gcc-4.4
more about release: https://wiki.linaro.org/WorkingGroups/ToolChain This version does not have any OE patches applied (other then zecke-no-host-includes.patch in gcc-cross). Built armv7-a console-image without problems with binutils-cross 2.20 - modified Angstrom distribution was used. Did not booted into is because linux-omap-psp 2.6.32 does not give working kernel when compiled with this version of GCC. Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/gcc-4.4-2010.09.inc34
-rw-r--r--recipes/gcc/gcc-cross-initial_4.4-2010.09.bb2
-rw-r--r--recipes/gcc/gcc-cross-intermediate_4.4-2010.09.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4-2010.09.bb9
-rw-r--r--recipes/gcc/gcc-cross_4.4-2010.09.bb11
-rw-r--r--recipes/gcc/gcc_4.4-2010.09.bb13
6 files changed, 71 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.4-2010.09.inc b/recipes/gcc/gcc-4.4-2010.09.inc
new file mode 100644
index 0000000000..9a75968b02
--- /dev/null
+++ b/recipes/gcc/gcc-4.4-2010.09.inc
@@ -0,0 +1,34 @@
+# No armeb and thumb patches - really needs checking
+DEFAULT_PREFERENCE = "-999"
+ARM_INSTRUCTION_SET = "arm"
+
+require gcc-common.inc
+LICENSE = "GPLv3"
+
+DEPENDS = "mpfr gmp"
+NATIVEDEPS = "mpfr-native gmp-native"
+
+INC_PR = "r0.1"
+
+
+SRC_URI = "http://launchpad.net/gcc-linaro/4.4/4.4-2010.09-1/+download/gcc-linaro-4.4-2010.09-1.tar.bz2;name=gcc444tarbz2 \
+ "
+
+S = "${WORKDIR}/gcc-linaro-${PV}-1/"
+SRC_URI[gcc444tarbz2.md5sum] = "ec12c8a52ff7b627eae9145c66d89990"
+SRC_URI[gcc444tarbz2.sha256sum] = "04a0693f2a095dfa8002a27ae835e34c11aae49142d9abe9d198997643f7a64b"
+
+# Language Overrides
+FORTRAN = ""
+JAVA = ""
+
+EXTRA_OECONF_BASE = " --enable-libssp \
+ --disable-bootstrap --disable-libgomp \
+ --disable-libmudflap"
+
+EXTRA_OECONF_INITIAL = "--disable-libmudflap --disable-libgomp --disable-libssp --enable-decimal-float=no"
+EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap --disable-libgomp --disable-libssp"
+
+EXTRA_OECONF_append_linux-uclibc = " --disable-decimal-float "
+EXTRA_OECONF_append_linux-uclibceabi = " --disable-decimal-float "
+EXTRA_OECONF_append_linux-uclibcspe = " --disable-decimal-float "
diff --git a/recipes/gcc/gcc-cross-initial_4.4-2010.09.bb b/recipes/gcc/gcc-cross-initial_4.4-2010.09.bb
new file mode 100644
index 0000000000..1639511362
--- /dev/null
+++ b/recipes/gcc/gcc-cross-initial_4.4-2010.09.bb
@@ -0,0 +1,2 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-initial.inc
diff --git a/recipes/gcc/gcc-cross-intermediate_4.4-2010.09.bb b/recipes/gcc/gcc-cross-intermediate_4.4-2010.09.bb
new file mode 100644
index 0000000000..eb59de9461
--- /dev/null
+++ b/recipes/gcc/gcc-cross-intermediate_4.4-2010.09.bb
@@ -0,0 +1,2 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-intermediate.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.4-2010.09.bb b/recipes/gcc/gcc-cross-sdk_4.4-2010.09.bb
new file mode 100644
index 0000000000..44abbcf75b
--- /dev/null
+++ b/recipes/gcc/gcc-cross-sdk_4.4-2010.09.bb
@@ -0,0 +1,9 @@
+inherit sdk
+
+require gcc-${PV}.inc
+require gcc-cross-sdk.inc
+PR = "${INC_PR}.1"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
diff --git a/recipes/gcc/gcc-cross_4.4-2010.09.bb b/recipes/gcc/gcc-cross_4.4-2010.09.bb
new file mode 100644
index 0000000000..8656ea466a
--- /dev/null
+++ b/recipes/gcc/gcc-cross_4.4-2010.09.bb
@@ -0,0 +1,11 @@
+require gcc-${PV}.inc
+require gcc-cross4.inc
+PR = "${INC_PR}.0"
+
+FILESDIR = "${FILE_DIRNAME}/gcc-4.4.4"
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch "
+
+EXTRA_OECONF += " --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/recipes/gcc/gcc_4.4-2010.09.bb b/recipes/gcc/gcc_4.4-2010.09.bb
new file mode 100644
index 0000000000..494451a81f
--- /dev/null
+++ b/recipes/gcc/gcc_4.4-2010.09.bb
@@ -0,0 +1,13 @@
+require gcc-${PV}.inc
+require gcc-configure-target.inc
+require gcc-package-target.inc
+PR = "${INC_PR}.0"
+
+# GCC 4.4.x installs crt* in a '4.4.x' dir....
+FILES_${PN} += "\
+ ${gcclibdir}/${TARGET_SYS}/*/*.o \
+"
+
+SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"