aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-31 01:13:28 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-05-31 01:23:15 +0200
commit2bd23469bebb3f491a8f75199056b7cec3933387 (patch)
tree6c502ed901eba6949efd19339f5738b0bfac6073 /recipes
parenta90701a8b544ce809c137ad44395c18a116466c4 (diff)
downloadopenembedded-2bd23469bebb3f491a8f75199056b7cec3933387.tar.gz
linux-kexecboot-2.6.24: fix compilation with gcc-4.3. Bump PR
Since some architectures don't support __udivdi3(). Signed-off-by: Segher Boessenkool <segher@kernel.crashing.org> Cc: john stultz <johnstul@us.ibm.com> Cc: Ingo Molnar <mingo@elte.hu> Signed-off-by: Andrew Morton <akpm@linux-foundation.org> Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch15
-rw-r--r--recipes/kexecboot/linux-kexecboot.inc2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.24.bb1
3 files changed, 17 insertions, 1 deletions
diff --git a/recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch b/recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
new file mode 100644
index 0000000000..9d7020d9f1
--- /dev/null
+++ b/recipes/kexecboot/linux-kexecboot-2.6.24/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
@@ -0,0 +1,15 @@
+Index: linux-2.6.24/include/linux/time.h
+===================================================================
+--- a/include/linux/time.h
++++ b/include/linux/time.h
+@@ -172,6 +172,10 @@ static inline void timespec_add_ns(struct timespec *a, u64 ns)
+ {
+ ns += a->tv_nsec;
+ while(unlikely(ns >= NSEC_PER_SEC)) {
++ /* The following asm() prevents the compiler from
++ * optimising this loop into a modulo operation. */
++ asm("" : "+r"(ns));
++
+ ns -= NSEC_PER_SEC;
+ a->tv_sec++;
+ }
diff --git a/recipes/kexecboot/linux-kexecboot.inc b/recipes/kexecboot/linux-kexecboot.inc
index 74767b0b12..5193212912 100644
--- a/recipes/kexecboot/linux-kexecboot.inc
+++ b/recipes/kexecboot/linux-kexecboot.inc
@@ -1,5 +1,5 @@
# We set PR here, since a change in the kexecboot recipe will need to get picked up by *all* the kernels:
-PR = "r12"
+PR = "r13"
SRC_URI = "file://defconfig"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.24.bb b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
index f728c7adc1..82484f45a0 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.24.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
@@ -21,6 +21,7 @@ DEFAULT_PREFERENCE_spitz = "1"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
+ file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
${RPSRC}/export_atags-r2.patch;patch=1;status=pending \
${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending \