aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-31 16:32:45 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-31 16:32:45 +0200
commit3002330a6a69bea5921d695e265377bc8b7a412e (patch)
tree0e6f39743b690328d4bb13e596e5f9d25fac0cff /recipes
parentb0947eb308c7bf35804ca57e3f74018a7f8c805c (diff)
downloadopenembedded-3002330a6a69bea5921d695e265377bc8b7a412e.tar.gz
gnet: sync with poky
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnet/files/configure_fix.patch58
-rw-r--r--recipes/gnet/files/pkgconfig_fix.patch12
-rw-r--r--recipes/gnet/gnet_svn.bb15
3 files changed, 77 insertions, 8 deletions
diff --git a/recipes/gnet/files/configure_fix.patch b/recipes/gnet/files/configure_fix.patch
new file mode 100644
index 0000000000..e6aadcc6a9
--- /dev/null
+++ b/recipes/gnet/files/configure_fix.patch
@@ -0,0 +1,58 @@
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -332,53 +332,6 @@ AC_DEFINE_UNQUOTED(GNET_SOCKADDR_FAMILY_
+ [$gnet_sockaddr_family_field_name],
+ [Name of sockaddr_storage family field])
+
+-dnl #######################################
+-dnl Check if abstract sockets are supported
+-dnl #######################################
+-
+-AC_LANG_PUSH(C)
+-AC_CACHE_CHECK([for abstract socket namespace availability],
+- ac_cv_gnet_have_abstract_sockets,
+- [AC_RUN_IFELSE([AC_LANG_PROGRAM(
+-[[
+-#include <sys/types.h>
+-#include <stdlib.h>
+-#include <string.h>
+-#include <stdio.h>
+-#include <sys/socket.h>
+-#include <sys/un.h>
+-#include <errno.h>
+-]],
+-[[
+- int listen_fd, len;
+- struct sockaddr_un addr;
+-
+- listen_fd = socket (PF_UNIX, SOCK_STREAM, 0);
+- if (listen_fd < 0) {
+- perror ("socket() failed: ");
+- exit (1);
+- }
+- memset (&addr, '\0', sizeof (addr));
+- addr.sun_family = AF_UNIX;
+- strcpy (addr.sun_path, "X/tmp/gnet-fake-socket-path-used-in-configure-test");
+- len = SUN_LEN (&addr); /* calculate size before adding the \0 */
+- addr.sun_path[0] = '\0'; /* this is what makes it abstract */
+-
+- if (bind (listen_fd, (struct sockaddr*) &addr, len) < 0) {
+- perror ("Abstract socket namespace bind() failed: ");
+- exit (1);
+- }
+- exit (0);
+-]])],
+- [ac_cv_gnet_have_abstract_sockets=yes],
+- [ac_cv_gnet_have_abstract_sockets=no]
+-)])
+-AC_LANG_POP(C)
+-
+-if test x$ac_cv_gnet_have_abstract_sockets = xyes ; then
+- AC_DEFINE(HAVE_ABSTRACT_SOCKETS,1,[Have abstract socket namespace])
+-fi
+-
+ ###############################
+ # Compiler characteristics
+ AC_C_CONST
diff --git a/recipes/gnet/files/pkgconfig_fix.patch b/recipes/gnet/files/pkgconfig_fix.patch
new file mode 100644
index 0000000000..a4a433f1ce
--- /dev/null
+++ b/recipes/gnet/files/pkgconfig_fix.patch
@@ -0,0 +1,12 @@
+Index: trunk/gnet-2.0.pc.in
+===================================================================
+--- trunk.orig/gnet-2.0.pc.in 2008-11-06 16:41:25.000000000 +0000
++++ trunk/gnet-2.0.pc.in 2008-11-06 16:42:23.000000000 +0000
+@@ -6,5 +6,6 @@
+ Name: Gnet
+ Description: A network compatibility layer library
+ Version: @VERSION@
++Requires: glib-2.0 gthread-2.0
+ Libs: -L${libdir} -lgnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ @GLIB_LIBS@ @GTHREAD_LIBS@
+-Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@
++Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/
diff --git a/recipes/gnet/gnet_svn.bb b/recipes/gnet/gnet_svn.bb
index c09b7f8b9c..ea2c92ff1a 100644
--- a/recipes/gnet/gnet_svn.bb
+++ b/recipes/gnet/gnet_svn.bb
@@ -3,10 +3,13 @@ LICENSE = "LGPL"
SECTION = "libs/network"
HOMEPAGE = "http://www.gnetlibrary.org"
DEPENDS = "glib-2.0"
-PV = "2.0.7+svn${SRCDATE}"
+PV = "2.0.7+svnr${SRCREV}"
+PR = "r1"
-SRC_URI = "svn://svn.gnome.org/svn/${PN}/;module=trunk \
- file://buildfix.patch;patch=1"
+SRC_URI = "svn://svn.gnome.org/svn/${PN}/;module=trunk;proto=http \
+ file://buildfix.patch;patch=1 \
+ file://configure_fix.patch;patch=1 \
+ file://pkgconfig_fix.patch;patch=1 "
S = "${WORKDIR}/trunk"
@@ -14,8 +17,4 @@ EXTRA_OECONF = "--disable-pthreads"
FILES_${PN}-dev += "${libdir}/gnet-2.0"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig