aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-16 21:36:08 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-16 21:41:01 -0700
commit353f19af2d03d1c7b6d425399bbe364fdcaed284 (patch)
tree1b1d227fb5403533d12510276e0c824553432713 /recipes
parent065d098d9c51b8afefe45cce9790f3f00aa8db8b (diff)
downloadopenembedded-353f19af2d03d1c7b6d425399bbe364fdcaed284.tar.gz
docbook-utils-native_0.6.14.bb: Get rid of do_stage
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/docbook-utils/docbook-utils-native_0.6.14.bb52
1 files changed, 23 insertions, 29 deletions
diff --git a/recipes/docbook-utils/docbook-utils-native_0.6.14.bb b/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
index 595aa50831..7d342ed3ae 100644
--- a/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
+++ b/recipes/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -1,11 +1,12 @@
SECTION = "console/utils"
LICENSE = "GPL"
-
-PR = "r2"
-
DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native"
+PR = "r2"
SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz"
+SRC_URI[md5sum] = "6b41b18c365c01f225bc417cf632d81c"
+SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9"
+
S = "${WORKDIR}/docbook-utils-${PV}"
inherit autotools native
@@ -13,33 +14,26 @@ inherit autotools native
do_configure_prepend() {
# Prevents the jw script to search on the build system.
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
-
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
}
-
-do_stage () {
- install -d ${STAGING_BINDIR_NATIVE}/
-
- # Installs the binaries and a bunch of other commonly used names for them.
- for doctype in html ps dvi man pdf rtf tex texi txt
- do
- install -m 0755 ${S}/bin/docbook2$doctype ${STAGING_BINDIR_NATIVE}/
- ln -sf docbook2x-$doctype ${STAGING_BINDIR_NATIVE}/db2$doctype
- ln -sf docbook2$doctype ${STAGING_BINDIR_NATIVE}/db2$doctype
- ln -sf docbook2$doctype ${STAGING_BINDIR_NATIVE}/docbook-to-$doctype
- done
- install -m 0755 ${S}/bin/jw ${STAGING_BINDIR_NATIVE}/
-
- for i in backends/dvi backends/html backends/man \
- backends/pdf backends/ps backends/rtf backends/tex \
- backends/texi backends/txt frontends/docbook \
- helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
- docbook-utils.dsl; do
- install -d ${STAGING_DATADIR}/sgml/docbook/utils-${PV}/`dirname $i`
- install ${S}/$i ${STAGING_DATADIR}/sgml/docbook/utils-${PV}/$i
- done
+do_install () {
+ install -d ${D}${bindir}
+ # Installs the binaries and a bunch of other commonly used names for them.
+ for doctype in html ps dvi man pdf rtf tex texi txt
+ do
+ install -m 0755 ${S}/bin/docbook2$doctype ${D}${bindir}/
+ ln -sf docbook2x-$doctype ${D}${bindir}/db2$doctype
+ ln -sf docbook2$doctype ${D}${bindir}/db2$doctype
+ ln -sf docbook2$doctype ${D}${bindir}/docbook-to-$doctype
+ done
+ install -m 0755 ${S}/bin/jw ${D}${bindir}/
+ for i in backends/dvi backends/html backends/man \
+ backends/pdf backends/ps backends/rtf backends/tex \
+ backends/texi backends/txt frontends/docbook \
+ helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
+ docbook-utils.dsl; do
+ install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
+ install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
+ done
}
-
-SRC_URI[md5sum] = "6b41b18c365c01f225bc417cf632d81c"
-SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9"