aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihar.hrachyshka@gmail.com>2009-05-24 10:54:00 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 17:45:40 -0400
commit47f74ab0bc9fc498e3565c5d780f40b001c6dcbc (patch)
treea33bc5eead914e3fe469f4b75cec2cb78f2d9905 /recipes
parent2d3750e3dae84c89c9c749f95cf6b3b6cca3e8ce (diff)
downloadopenembedded-47f74ab0bc9fc498e3565c5d780f40b001c6dcbc.tar.gz
udev: fixed obsolete udevadm syntax for udev init.d script.
Fixed the following warning message when executing udev init script: "udevadm control commands requires the --<command> format, this will stop working in a future release." Signed-off-by: Ihar Hrachyshka <ihar.hrachyshka@gmail.com> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/udev/udev-141/init4
-rw-r--r--recipes/udev/udev_141.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/udev/udev-141/init b/recipes/udev/udev-141/init
index efe44708ca..7188b5a777 100644
--- a/recipes/udev/udev-141/init
+++ b/recipes/udev/udev-141/init
@@ -56,10 +56,10 @@ kill_udevd > "/dev/null" 2>&1
echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
/sbin/udevd -d
- /sbin/udevadm control env STARTUP=1
+ /sbin/udevadm control --env STARTUP=1
if [ "$not_first_boot" != "" ];then
/sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
- (/sbin/udevadm settle --timeout=3; /sbin/udevadm control env STARTUP=)&
+ (/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env STARTUP=)&
if [ "$DEVCACHE" != "" ]; then
rm -f /tmp/uname
rm -f /tmp/cmdline
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index e687989e9f..040189faf5 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r8"
+PR = "r9"
# needed for init.d script
RDEPENDS_udev += "udev-utils"