aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-12 09:53:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-19 17:01:24 +0200
commit5083d49cb3ad295a66a63ab1aa688c64d5f347d3 (patch)
tree3a726b02015f1e05ff3a9d8f1a71b7fdf5374fbe /recipes
parent8a50e39aeaaa04ae0596ad6a3a10bc251acd64cc (diff)
downloadopenembedded-5083d49cb3ad295a66a63ab1aa688c64d5f347d3.tar.gz
navit: bump SRCREV (also for navit-icons) and add new osd layout from undrwater for SHR as default
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/navit/files/shr/osd.xml35
-rw-r--r--recipes/navit/navit-icons_svn.bb2
-rw-r--r--recipes/navit/navit_svn.bb6
3 files changed, 29 insertions, 14 deletions
diff --git a/recipes/navit/files/shr/osd.xml b/recipes/navit/files/shr/osd.xml
index a8a97d74c9..789e1c9221 100644
--- a/recipes/navit/files/shr/osd.xml
+++ b/recipes/navit/files/shr/osd.xml
@@ -1,32 +1,47 @@
<!-- FreeRunner Layout 3 -->
- <osd enabled="yes" type="text" label="${navigation.item.street_name} ${navigation.item[1].street_name_systematic}" x="0" y="0" w="480" h="30" align="0" background_color="#000000cc" font_size="300" />
+ <!--osd enabled="yes" type="text" label="${navigation.item.street_name} ${navigation.item[1].street_name_systematic}" x="0" y="0" w="480" h="30" align="0" background_color="#000000cc" font_size="300" />
<osd enabled="yes" type="gps_status" x="430" y="0" w="65" h="30" align="0" background_color="#000000cc" font_size="300" />
<osd enabled="yes" type="compass" align="0" font_size="350" x="0" y="30" w="150" h="150" background_color="#000000cc" />
- <osd enabled="yes" type="navigation_next_turn" x="-150" y="30" w="150" h="60" background_color="#000000cc" />
+ <osd enabled="yes" type="navigation_next_turn" x="-150" y="30" w="150" h="60" background_color="#000000cc" icon_src="$NAVIT_SHAREDIR/xpm/%s_wh_48_48.png" />
<osd enabled="yes" type="text" label="${navigation.item[1].length[named]}" x="-150" y="90" w="150" h="40" align="0" background_color="#000000cc" font_size="450"/>
- <osd enabled="yes" type="button" x="-55" y="-90" command="zoom_in()" src="gui_zoom_in.svg"/>
- <osd enabled="yes" type="button" x="5" y="-90" command="zoom_out()" src="gui_zoom_out.svg"/>
+ <osd enabled="yes" type="button" x="-55" y="-90" command="zoom_in()" src="gui_zoom_in_48_48.png"/>
+ <osd enabled="yes" type="button" x="5" y="-90" command="zoom_out()" src="gui_zoom_out_48_48.png"/>
<osd enabled="yes" type="text" label="${vehicle.position_speed}" x="120" y="-50" w="240" h="25" align="0" background_color="#000000cc" font_size="280"/>
<osd enabled="yes" type="text" label="ETA:${navigation.item.destination_time[arrival]}" x="0" y="-25" w="160" h="25" align="4" background_color="#000000cc" font_size="350" />
<osd enabled="yes" type="text" label="TL:${navigation.item.destination_time[remaining]}" x="160" y="-25" w="160" h="25" align="4" background_color="#000000cc" font_size="350" />
- <osd enabled="yes" type="text" label="Dist:${navigation.item.destination_length[named]}" x="320" y="-25" w="160" h="25" align="4" background_color="#000000cc" font_size="350" />
+ <osd enabled="yes" type="text" label="Dist:${navigation.item.destination_length[named]}" x="320" y="-25" w="160" h="25" align="4" background_color="#000000cc" font_size="350" /-->
<!-- / FreeRunner Layout 3 -->
+ <!-- FreeRunner Layout from undrwater -->
+ <osd enabled="yes" type="text" label="${navigation.item.street_name} ${navigation.item[1].street_name_systematic}" x="0" y="0" w="480" h="30" align="0" background_color="#3e6fd2cc" font_size="400" />
+ <osd enabled="yes" type="gps_status" x="430" y="0" w="65" h="30" align="0" background_color="#3e6fd2cc" font_size="400" />
+ <osd enabled="yes" type="navigation_next_turn" x="165" y="58" w="150" h="60" background_color="#3e6fd2cc" icon_src="$NAVIT_SHAREDIR/xpm/%s_wh_48_48.png" />
+ <osd enabled="yes" type="text" label="${navigation.item[1].length[named]}" x="165" y="118" w="150" h="40" align="" background_color="#3e6fd2cc" font_size="450"/>
+ <osd enabled="yes" type="button" x="-55" y="-90" command="zoom_in()" src="/usr/share/navit/xpm/gui_zoom_in_48_48.png"/>
+ <osd enabled="yes" type="button" x="5" y="-90" command="zoom_out()" src="/usr/share/navit/xpm/gui_zoom_out_48_48.png"/>
+ <osd enabled="yes" type="text" label="${vehicle.position_speed}" x="120" y="-105" w="240" h="80" align="0" background_color="#3e6fd2cc" font_size="480"/>
+ <osd enabled="yes" type="text" label="ETA:${navigation.item.destination_time[arrival]}" x="0" y="-25" w="160" h="25"align="4" background_color="#3e6fd2cc" font_size="400" />
+ <osd enabled="yes" type="text" label="TL:${navigation.item.destination_time[remaining]}" x="160" y="-25" w="160" h="25" align="4" background_color="#3e6fd2cc" font_size="400" />
+ <osd enabled="yes" type="text" label="Dist:${navigation.item.destination_length[named]}" x="320" y="-25" w="160" h="25" align="4" background_color="#3e6fd2cc" font_size="400" />
+ <!-- Next turn is onto ROADNAME -->
+ <osd enabled="yes" type="text" label="Turn onto: ${navigation.item[1].street_name} ${navigation.item[1].street_name_systematic}" x="0" y="30" w="480" h="28" align="4" background_color="#3e6fd2cc" font_size="400"/>
+ <!-- / FreeRunner Layout from undrwater -->
+
<!-- Mineque's OSD 003 Layout -->
- <!--osd enabled="yes" type="text" label="Currently On ${navigation.item.street_name} ${navigation.item[1].street_name_systematic}" x="0" y="0" w="735" h="35" align="16" background_color="#a60c0f00" font_size="430" src="gui_fullscreen.svg" />
+ <!--osd enabled="yes" type="text" label="Currently On ${navigation.item.street_name} ${navigation.item[1].street_name_systematic}" x="0" y="0" w="735" h="35" align="16" background_color="#a60c0f00" font_size="430" src="gui_fullscreen_48_48.png" />
<osd enabled="yes" type="gps_status" x="735" y="0" w="65" h="30" align="0" background_color="#a60c0f00" font_size="300" />
<osd enabled="yes" type="text" label="ETA:${navigation.item.destination_time[arrival]}" x="50" y="-100" w="275" h="70" align="4" background_color="#a60c0f01" font_size="500" />
<osd enabled="yes" type="text" label="TL:${navigation.item.destination_time[remaining]}" x="475" y="-100" w="275" h="70"align="4" background_color="#a60c0f00" font_size="500" />
<osd enabled="yes" type="text" label="Dist:${navigation.item.destination_length[named]}" x="50" y="-60" w="275" h="70" align="4" background_color="#a60c0f00" font_size="500" />
<osd enabled="yes" type="text" label="${vehicle.position_speed} / ${tracking.item.route_speed}" x="475" y="-60" w="275" h="70" align="4" background_color="#a60c0f00" font_size="500"/>
<osd enabled="yes" type="text" label="${navigation.item[1].length[named]}" x="325" y="-40" w="150" h="40" align="0" background_color="#a60c0f00" font_size="500"/>
- <osd enabled="yes" type="navigation_next_turn" x="325" y="-135" w="150" h="100" align="15" background_color="#a60c0f00" />
+ <osd enabled="yes" type="navigation_next_turn" x="325" y="-135" w="150" h="100" align="15" background_color="#a60c0f00" icon_src="$NAVIT_SHAREDIR/xpm/%s_wh_48_48.png" />
<osd enabled="yes" type="button" x="0" y="-120" w="800" h="120" command="" src="/home/mineque/.navit/skins/Mineque_003/M_003_01.png" />
<osd enabled="yes" type="button" x="0" y="0" w="800" h="35" command="" src="/home/mineque/.navit/skins/Mineque_003/M_003_02.png" />
- <osd enabled="yes" type="button" x="5" y="35" command="gui.fullscreen()" src="gui_fullscreen.svg"/>
+ <osd enabled="yes" type="button" x="5" y="35" command="gui.fullscreen()" src="gui_fullscreen_48_48.png"/>
<osd enabled="no" type="button" x="300" y="100" command="gui.menu()" src="menu.xpm"/>
- <osd enabled="yes" type="button" x="5" y="475" command="zoom_in()" src="gui_zoom_in.svg"/>
- <osd enabled="yes" type="button" x="-53" y="475" command="zoom_out()" src="gui_zoom_out.svg"/-->
+ <osd enabled="yes" type="button" x="5" y="475" command="zoom_in()" src="gui_zoom_in_48_48.png"/>
+ <osd enabled="yes" type="button" x="-53" y="475" command="zoom_out()" src="gui_zoom_out_48_48.png"/-->
<!-- / Mineque's OSD 003 Layout -->
<!-- Default -->
diff --git a/recipes/navit/navit-icons_svn.bb b/recipes/navit/navit-icons_svn.bb
index 5846e651ca..92f7a5ee58 100644
--- a/recipes/navit/navit-icons_svn.bb
+++ b/recipes/navit/navit-icons_svn.bb
@@ -18,7 +18,7 @@ inherit autotools
FILES_${PN} = " /usr/share/navit/xpm/"
-SRCREV = "3135"
+SRCREV = "3276"
#use different URL than navit_svn does, to prevent upgrade/downgrade cycle in downloads dir
SRC_URI = "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk/navit/navit;module=xpm;proto=https \
diff --git a/recipes/navit/navit_svn.bb b/recipes/navit/navit_svn.bb
index 5c671897c0..7cde0381d6 100644
--- a/recipes/navit/navit_svn.bb
+++ b/recipes/navit/navit_svn.bb
@@ -7,13 +7,13 @@ S = "${WORKDIR}/navit"
# override navit.inc RRECOMMENDS, we only suggest a text2speech app
RRECOMMENDS = "gpsd"
-RSUGGESTS = "flite espeak
+RSUGGESTS_${PN} = "flite espeak"
-DEPENDS_shr += " librsvg-native"
+DEPENDS_shr += " gd librsvg-native"
RDEPENDS = " navit-icons"
EXTRA_OECONF += " --enable-svg2png-scaling-flag=32 --disable-speech-speech-dispatcher --enable-cache-size=20971520"
-SRCREV = "3224"
+SRCREV = "3279"
SRC_URI = "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk;module=navit;proto=https"
EXTRA_AUTORECONF = " -I m4"