aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-23 15:59:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-23 15:59:21 +0200
commit7209ba7dd74286db6a13e67e28dbe16c740a0d02 (patch)
tree685458cf8e651efce7c6b39490fb9be0625d6b76 /recipes
parenta292887f0a0534d65336fac3131325742256cbfd (diff)
downloadopenembedded-7209ba7dd74286db6a13e67e28dbe16c740a0d02.tar.gz
ekiga: update to 3.2.0
opal: update to 3.6.1, fix QA ptlib: update to 2.6.1
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ekiga/ekiga_3.2.0.bb18
-rw-r--r--recipes/ekiga/opal_3.5.2.bb4
-rw-r--r--recipes/ekiga/opal_3.6.1.bb29
-rw-r--r--recipes/ekiga/ptlib_2.6.1.bb30
4 files changed, 80 insertions, 1 deletions
diff --git a/recipes/ekiga/ekiga_3.2.0.bb b/recipes/ekiga/ekiga_3.2.0.bb
new file mode 100644
index 0000000000..3a63015d66
--- /dev/null
+++ b/recipes/ekiga/ekiga_3.2.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gnome videoconferencing application"
+LICENSE = "GPLv2"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit gnome
+DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
+RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+
+EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
+
diff --git a/recipes/ekiga/opal_3.5.2.bb b/recipes/ekiga/opal_3.5.2.bb
index ea4685d4c5..b54e337ecb 100644
--- a/recipes/ekiga/opal_3.5.2.bb
+++ b/recipes/ekiga/opal_3.5.2.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
LICENSE = "MPL"
-PR = "r1"
+PR = "r2"
inherit gnome
@@ -14,6 +14,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
ARM_INSTRUCTION_SET = "arm"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
do_configure() {
libtoolize --force
gnu-configize
diff --git a/recipes/ekiga/opal_3.6.1.bb b/recipes/ekiga/opal_3.6.1.bb
new file mode 100644
index 0000000000..502c344b13
--- /dev/null
+++ b/recipes/ekiga/opal_3.6.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/ekiga/ptlib_2.6.1.bb b/recipes/ekiga/ptlib_2.6.1.bb
new file mode 100644
index 0000000000..93a3bd8c96
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.6.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+