aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2010-05-21 19:57:05 +0200
committerKlaus Kurzmann <mok@fluxnetz.de>2010-05-21 19:57:05 +0200
commitd1b03808e6b4377e0ce0d9d4ac4a2849d56ba41f (patch)
tree93c71bb785f0940c7753ff7068612e0933a1ab34 /recipes
parent2c153f33b8ebb807a622ad9ae92ed5341a356740 (diff)
downloadopenembedded-d1b03808e6b4377e0ce0d9d4ac4a2849d56ba41f.tar.gz
linux-openmoko-devel_git.bb: apply getline fix for scripts/unidef.c
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-openmoko-devel_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-devel_git.bb b/recipes/linux/linux-openmoko-devel_git.bb
index 21d227d6dd..9d4aa22c07 100644
--- a/recipes/linux/linux-openmoko-devel_git.bb
+++ b/recipes/linux/linux-openmoko-devel_git.bb
@@ -20,6 +20,15 @@ CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
do_configure_prepend() {
+
+ # Rename getline in ./scripts/unifdef.c
+ # Kernels up to 2.6.29 are currently failing to build unifdef.c,
+ # clashing with exposed getline() from <stdio.h>
+ # see https://patchwork.kernel.org/patch/11166/
+ # committed in 2.6.29 (commit d15bd1067b1fcb2b7250d22bc0c7c7fea0b759f7)
+
+ sed -i -e 's/getline/parseline/g' ${S}/scripts/unifdef.c
+
install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
}