aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2009-08-24 22:00:51 +0100
committerKoen Kooi <koen@openembedded.org>2009-08-25 11:47:05 +0200
commitf1b3ee840783ceb38067e26c05184e723cf0b214 (patch)
tree4b10ae15e225aff7aa0c5b6aa2c4be14d4a4a4e2 /recipes
parent571084dd3f9874b27d918b077cd3e2b694df78e0 (diff)
downloadopenembedded-f1b3ee840783ceb38067e26c05184e723cf0b214.tar.gz
gnome-games: fix previous bad patch -I/SDL error
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnome/gnome-games_2.24.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/gnome/gnome-games_2.24.0.bb b/recipes/gnome/gnome-games_2.24.0.bb
index cc795e14a5..6449c82c8a 100644
--- a/recipes/gnome/gnome-games_2.24.0.bb
+++ b/recipes/gnome/gnome-games_2.24.0.bb
@@ -24,7 +24,10 @@ do_configure_prepend() {
do_configure_append() {
for i in $(find ${S} -name "Makefile") ; do
- sed -i -e s:'I/usr/include'::g -e s:'-I /usr/include -I /usr/local/include'::g $i
+ sed -i \
+ -e s:'-I/usr/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
+ -e s:'-I/usr/local/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
+ $i
done
}