aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-22 00:26:28 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-22 00:26:28 +0400
commit255eb9e2b29fb4c027a48c804b336c701f78ea75 (patch)
tree6a8774bfd0a912652a5ab62ca43d8c191e330871 /recipes
parent213e66e9ca111c562558ffb5e19c940597d6e270 (diff)
parenta185021b298010edd0a212bfca9634c95355bdd5 (diff)
downloadopenembedded-255eb9e2b29fb4c027a48c804b336c701f78ea75.tar.gz
Merge branch 'org.openembedded.dev' of git://git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ezx/ezx-gen-blob_git.bb (renamed from recipes/ezx/ezx-gen-blob_svn.bb)10
-rw-r--r--recipes/ezx/moto-boot-usb-native_git.bb (renamed from recipes/ezx/ezx-boot-usb-native_svn.bb)18
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.5.bb5
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc3
-rw-r--r--recipes/linux/openezx-kernel_git.bb4
5 files changed, 20 insertions, 20 deletions
diff --git a/recipes/ezx/ezx-gen-blob_svn.bb b/recipes/ezx/ezx-gen-blob_git.bb
index 39cec891a2..5ebcad100c 100644
--- a/recipes/ezx/ezx-gen-blob_svn.bb
+++ b/recipes/ezx/ezx-gen-blob_git.bb
@@ -5,16 +5,16 @@ HOMEPAGE = "http://people.openezx.org/wyrm/gen-blob"
LICENSE = "GPL"
PROVIDES = "virtual/bootloader"
DEPENDS = "virtual/kernel"
-SRCREV = "2519"
-PV = "1.0.0+svnr${SRCPV}"
+SRCREV = "48d1cf4dbc8228b982ff40c36922769f70347da1"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "r0"
PE = "1"
-PR = "r2"
SRC_URI = "\
- svn://svn.openezx.org/trunk/src/blob/;module=gen-blob;proto=http \
+ git://git.openezx.org/gen-blob.git;protocol=git;branch=master \
file://remove-bogus-sed.patch \
"
-S = "${WORKDIR}/gen-blob"
+S = "${WORKDIR}/git"
inherit autotools
diff --git a/recipes/ezx/ezx-boot-usb-native_svn.bb b/recipes/ezx/moto-boot-usb-native_git.bb
index 280de30e24..e6fdaa19cb 100644
--- a/recipes/ezx/ezx-boot-usb-native_svn.bb
+++ b/recipes/ezx/moto-boot-usb-native_git.bb
@@ -3,11 +3,13 @@ DEPENDS = "virtual/libusb0-native virtual/kernel"
SECTION = "devel"
AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
LICENSE = "GPL"
-SRCREV = "2522"
-PV = "0.3.0+svnr${SRCPV}"
+SRCREV = "d7136c6c9fe9d62b8f3defccef5dca47258bef63"
+PV = "0.3.0+gitr${SRCPV}"
+PR = "r0"
+PE = "1"
-SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
-S = "${WORKDIR}/boot_usb"
+SRC_URI = "git://git.openezx.org/moto-boot-usb.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
@@ -15,15 +17,11 @@ inherit autotools native
do_deploy() {
install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 src/boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
-}
-
-do_stage() {
- :
+ install -m 0755 src/moto-boot-usb ${DEPLOY_DIR_TOOLS}/moto-boot-usb-${PV}
}
do_install() {
- :
+ :
}
addtask deploy before do_build after do_compile
diff --git a/recipes/gcc/gcc-cross-sdk_4.5.bb b/recipes/gcc/gcc-cross-sdk_4.5.bb
index a316cd282e..a3b2215e2b 100644
--- a/recipes/gcc/gcc-cross-sdk_4.5.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.5.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
inherit sdk
@@ -7,4 +7,5 @@ require gcc-cross-sdk.inc
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+ --with-system-zlib"
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index eb15bb55e7..797a5add79 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -1,7 +1,7 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-INC_PR = "r5"
+INC_PR = "r6"
inherit sdk
@@ -18,6 +18,7 @@ do_install_append() {
# we don't care about these infos, installed from binutils
rm -f ${D}/${infodir}/{configure,standards,bfd}.info
+ rm -f ${D}/${infodir}/dir
# We use libiberty from binutils
rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a
diff --git a/recipes/linux/openezx-kernel_git.bb b/recipes/linux/openezx-kernel_git.bb
index 76929e0a47..efd782d0e8 100644
--- a/recipes/linux/openezx-kernel_git.bb
+++ b/recipes/linux/openezx-kernel_git.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "OpenEZX 2.6 Linux Development Kernel for the Motorola EZX GSM phones"
AUTHOR = "The OpenEZX Team <openezx-devel@lists.openezx.org>"
HOMEPAGE = "http://www.openezx.org"
-SRCREV = "c485cc5953bbebdab1c52032754accca75031837"
+SRCREV = "ce4e7c09de3ce6fb582440a7c7b9682527f36521"
KV = "2.6.34-oe"
PV = "${KV}+gitr${SRCREV}"
-PR = "r5"
+PR = "r6"
require linux.inc