aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-11-21 19:51:05 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-11-21 19:52:48 -0200
commit2f15c139108411520a235708e3a3b697eb12b497 (patch)
treeb71ad2206fa0981802bde6433bcbca77e0d40c66 /recipes
parentbfdc00bd2988b41ab28536586164591067216f0a (diff)
downloadopenembedded-2f15c139108411520a235708e3a3b697eb12b497.tar.gz
squashfs-tools: allow setting of SRC_URI before loading .inc
Without this change bitbake due a fetcher failure because SRC_URI is then cached and later changed. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/squashfs-tools/squashfs-tools.inc4
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb7
2 files changed, 6 insertions, 5 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools.inc b/recipes/squashfs-tools/squashfs-tools.inc
index aa75eaa898..fb5a648545 100644
--- a/recipes/squashfs-tools/squashfs-tools.inc
+++ b/recipes/squashfs-tools/squashfs-tools.inc
@@ -2,14 +2,14 @@ DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
SECTION = "base"
LICENSE = "GPLv2"
DEPENDS = "zlib"
-INC_PR = "r2"
+INC_PR = "r3"
S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
# required to share same place with -lzma specific packages
FILESPATHPKG = "squashfs-tools-${PV}:squashfs-tools:files"
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz"
+SRC_URI ?= "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz"
prefix = ""
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 29d82a83b0..886c095883 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,9 +1,10 @@
-require squashfs-tools.inc
-PR = "${INC_PR}.2"
-
# This override is required since this has not yet been released
SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE} \
http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
+
+require squashfs-tools.inc
+PR = "${INC_PR}.2"
+
S = "${WORKDIR}/squashfs/squashfs-tools"
EXTRA_OEMAKE += "LZMA_SUPPORT=1 LZMA_DIR=../.."