aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Dietze <mdietze@gmail.com>2013-03-02 17:11:15 +0100
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:27:30 +0100
commit5f31b43b3ad830dcc4286ed2c87b396c2e8037a6 (patch)
tree4c97ff0ad572322e148116188bc7fcdd17bbfe38 /recipes
parent2c12aaf952f2dbb9e31f76e029a8216d6545bc62 (diff)
downloadopenembedded-5f31b43b3ad830dcc4286ed2c87b396c2e8037a6.tar.gz
nylong-config: fixed postinst script to not fail if httpd is not yet running
Diffstat (limited to 'recipes')
-rw-r--r--recipes/nylon/nylon-config.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/nylon/nylon-config.bb b/recipes/nylon/nylon-config.bb
index 76f78a97f7..d1648184e0 100644
--- a/recipes/nylon/nylon-config.bb
+++ b/recipes/nylon/nylon-config.bb
@@ -24,7 +24,7 @@ if test "x$D" != "x"; then
fi
# Create resolv.conf-link to ppp-file
-rm /etc/resolv.conf
+rm -f /etc/resolv.conf
ln -s /etc/ppp/resolv.conf /etc/resolv.conf
# enable factorydefaults
@@ -34,7 +34,8 @@ update-rc.d factorydefaults start 90 2 .
perl -I /srv/www/cgi-bin -MConfig::IFace -e '$w=new Config::IFace(); $v = $w->read(); $v->{auto} = {0=>"lo",1=>eth0,2=>"wlan0",3=>"wlan1",4=>"ath0",5=>"ath1"}; $w->write($v)'
update-rc.d busybox-httpd start 40 2 3 4 5 .
-/etc/init.d/busybox-httpd restart
+/etc/init.d/busybox-httpd stop || true
+/etc/init.d/busybox-httpd start
}
FILES_${PN} += "/srv"