aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-15 11:20:56 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-15 11:20:56 +0200
commite2ef88a97bf50903c3e2042703e8d6fb5d5a7655 (patch)
tree3b5fc749afc56ed2e4948263e80b856426ce9b95 /recipes
parentb1c45cdc203019a98e2a568235b98c7aa2f15ab6 (diff)
downloadopenembedded-e2ef88a97bf50903c3e2042703e8d6fb5d5a7655.tar.gz
mpd: update to 0.15
Diffstat (limited to 'recipes')
-rw-r--r--recipes/musicpd/mpd_0.15.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/musicpd/mpd_0.15.bb b/recipes/musicpd/mpd_0.15.bb
new file mode 100644
index 0000000000..8a8573fab9
--- /dev/null
+++ b/recipes/musicpd/mpd_0.15.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+SECTION = "console/multimedia"
+LICENSE = "GPLv2"
+DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag lame', d)}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.bz2 \
+ file://mpd/mpd.conf \
+ file://mpd/mpd.init"
+
+inherit autotools update-rc.d
+INITSCRIPT_NAME = "mpd"
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "\
+ --enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --with-faad-libraries=${STAGING_LIBDIR} \
+ --with-faad-includes=${STAGING_INCDIR} \
+ --disable-curl \
+ --disable-ffmpeg \
+ --disable-jack \
+ --enable-pulse \
+ --enable-mod \
+ --disable-oggflac \
+ --with-lame-includes=${STAGING_INCDIR}"
+
+do_compile_prepend() {
+ find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
+ install -m 644 ${WORKDIR}/mpd/mpd.conf ${D}${sysconfdir}/mpd.conf
+}
+