summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-10-14 09:53:43 +0200
committerKoen Kooi <koen@openembedded.org>2010-10-14 09:53:43 +0200
commit5e21955af7b06deeebafd7e3ffaa8b83aabb0d12 (patch)
tree68542268923602c4e7c4e687fbdbaf3e5a7f8e40 /recipes
parent65ae48d1c7299e300d53e6df6ecac128a10288a0 (diff)
downloadopenembedded-5e21955af7b06deeebafd7e3ffaa8b83aabb0d12.tar.gz
omap3-sgx-modules: make patch apply with all versions of patch
Diffstat (limited to 'recipes')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-recent-kernels.patch42
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb2
2 files changed, 22 insertions, 22 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-recent-kernels.patch b/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-recent-kernels.patch
index 1ceba8b139..fd75fe42c2 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-recent-kernels.patch
+++ b/recipes/powervr-drivers/omap3-sgx-modules/0002-Compile-fixes-for-recent-kernels.patch
@@ -1,23 +1,23 @@
---- GFX_Linux_KM/services4/system/omap3630/sysutils_linux.c-orig 2010-07-30 07:15:01.000000000 -0700
-+++ GFX_Linux_KM/services4/system/omap3630/sysutils_linux.c 2010-10-07 07:49:32.000000000 -0700
+--- /tmp/sysutils_linux.c 2010-10-14 09:46:08.000000000 +0200
++++ GFX_Linux_KM/services4/system/omap3630/sysutils_linux.c 2010-10-14 09:47:20.000000000 +0200
@@ -32,6 +32,12 @@
- #include <asm/bug.h>
- #include <linux/platform_device.h>
-
-+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,33))
-+#include <linux/semaphore.h>
-+#include <asm-generic/resource.h>
-+#include <plat/omap-pm.h>
-+#else
-+
- #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,31))
- #include <linux/semaphore.h>
- #include <plat/resource.h>
+ #include <asm/bug.h>
+ #include <linux/platform_device.h>
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,33))
++#include <linux/semaphore.h>
++#include <asm-generic/resource.h>
++#include <plat/omap-pm.h>
++#else
++
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,31))
+ #include <linux/semaphore.h>
+ #include <plat/resource.h>
@@ -49,6 +55,7 @@
- #endif
- #endif
- #endif
-+#endif
-
- #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,27)) && \
- (LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,29))
+ #endif
+ #endif
+ #endif
++#endif
+
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,27)) && \
+ (LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,29))
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
index 5c4e15de6d..481b504e29 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
@@ -23,7 +23,7 @@ S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM"
inherit module
-MACHINE_KERNEL_PR_append = "e"
+MACHINE_KERNEL_PR_append = "f"
PVRBUILD = "release"