summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-13 21:27:05 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-13 21:29:16 +0200
commit7e8f12e3c6e76a1b190d551d3ff5c796d5a59df2 (patch)
treea642f8f72d402cbc05257b0ea38279c5841a6b09 /recipes
parentb2d4cb84a117a04b625f2cda1d249a994da56780 (diff)
downloadopenembedded-7e8f12e3c6e76a1b190d551d3ff5c796d5a59df2.tar.gz
u-boot_git: added dont-inline-weak-symbols patch for hawkboard
u-boot did not build for hawkboard due weak symbols and inlining. this is a known issue with u-boot 2009.8 and git versions shortly after that added the already existing patch to SRC_URI_hawkboard Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/u-boot/u-boot-git/dont-inline-weak-symbols.patch45
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 47 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/dont-inline-weak-symbols.patch b/recipes/u-boot/u-boot-git/dont-inline-weak-symbols.patch
new file mode 100644
index 0000000000..5931ccf00b
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/dont-inline-weak-symbols.patch
@@ -0,0 +1,45 @@
+Patch initially created by Ron Lee and archived in OE patchwork at
+http://patchwork.openembedded.org/patch/1534/.
+
+GCC 4.4 complains about this now.
+
+Signed-off-by: Ron Lee <ron@debian.org>
+---
+ lib_arm/board.c | 18 +++++++++---------
+ 1 files changed, 9 insertions(+), 9 deletions(-)
+
+--- a/lib_arm/board.c
++++ b/lib_arm/board.c
+@@ -124,23 +124,23 @@
+ * May be supplied by boards if desired
+ */
+ void inline __coloured_LED_init (void) {}
+-void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
++void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
+ void inline __red_LED_on (void) {}
+-void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
++void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
+ void inline __red_LED_off(void) {}
+-void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
++void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
+ void inline __green_LED_on(void) {}
+-void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
++void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
+ void inline __green_LED_off(void) {}
+-void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
++void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
+ void inline __yellow_LED_on(void) {}
+-void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
++void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
+ void inline __yellow_LED_off(void) {}
+-void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
++void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
+ void inline __blue_LED_on(void) {}
+-void inline blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
++void blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
+ void inline __blue_LED_off(void) {}
+-void inline blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
++void blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
+
+ /************************************************************************
+ * Init Utilities *
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 3d3b44e6b7..1e3f1aaa43 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r64"
+PR ="r65"
FILESPATHPKG =. "u-boot-git:"
@@ -254,6 +254,7 @@ PV_da850-omapl138-evm = "2009.11+${PR}+gitr${SRCREV}"
# hawkboard - master branch (hawk still .07beta)
SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
+SRC_URI_hawkboard += "file://dont-inline-weak-symbols.patch"
SRCREV_hawkboard = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
PV_hawkboard = "2009.08+gitr${SRCREV}"