summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorVitus Jensen <vjensen@gmx.de>2010-09-06 13:54:03 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-13 21:30:28 -0700
commita4091df206a67ce8212f2eb0b602b5179b894579 (patch)
tree9877858241d119e171591c510962e22cd73263ef /recipes
parent8a88368dbe21674fbe9ede83898fdcd7d0c18d14 (diff)
downloadopenembedded-a4091df206a67ce8212f2eb0b602b5179b894579.tar.gz
htmldoc_1.8.27:: merge native and non-native recipes
Signed-off-by: Vitus Jensen <vjensen@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/htmldoc/htmldoc-native_1.8.27.bb37
-rw-r--r--recipes/htmldoc/htmldoc_1.8.27.bb17
2 files changed, 14 insertions, 40 deletions
diff --git a/recipes/htmldoc/htmldoc-native_1.8.27.bb b/recipes/htmldoc/htmldoc-native_1.8.27.bb
deleted file mode 100644
index 36a6dee7c9..0000000000
--- a/recipes/htmldoc/htmldoc-native_1.8.27.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-require htmldoc.inc
-PR = "r2"
-
-
-SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
-file://paths_1.8.27.patch"
-
-
-inherit autotools native
-
-EXTRA_AUTORECONF += "--exclude=autoheader"
-EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
- --with-gui=no"
-
-
-do_compile() {
- cd htmldoc && oe_runmake all ; cd ${S}
-}
-
-
-do_stage () {
- install -d ${STAGING_DATADIR}/htmldoc/fonts
- install -m 0644 ${S}/fonts/*.afm ${STAGING_DATADIR}/htmldoc/fonts/
- install -m 0644 ${S}/fonts/*.pfa ${STAGING_DATADIR}/htmldoc/fonts/
-
- install -d ${STAGING_DATADIR}/htmldoc/data
- install -m 0644 ${S}/data/* ${STAGING_DATADIR}/htmldoc/data/
-
- install -d ${STAGING_DIR_HOST}${layout_mandir}/man1
- install -m 0644 ${S}/doc/htmldoc.man ${STAGING_DIR_HOST}${layout_mandir}/man1/
-
- install -d ${STAGING_BINDIR}
- install -m 0755 ${S}/htmldoc/htmldoc ${STAGING_BINDIR}/
-}
-
-SRC_URI[md5sum] = "35589e7b8fe9c54e11be87cd5aec4dcc"
-SRC_URI[sha256sum] = "89ffd223734268375dc959c200622dc5f167576c5cad9d7ce4bd7567faeb9613"
diff --git a/recipes/htmldoc/htmldoc_1.8.27.bb b/recipes/htmldoc/htmldoc_1.8.27.bb
index bb5ce8b78a..84df876226 100644
--- a/recipes/htmldoc/htmldoc_1.8.27.bb
+++ b/recipes/htmldoc/htmldoc_1.8.27.bb
@@ -1,10 +1,11 @@
require htmldoc.inc
-DEPENDS += "htmldoc-native"
-PR = "r2"
+DEPENDS_pn-htmldoc += "htmldoc-native"
+PR = "r3"
SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
-file://paths_1.8.27.patch"
+ file://paths_1.8.27.patch \
+ "
inherit autotools pkgconfig
@@ -16,6 +17,16 @@ EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
FILES_${PN} += "${datadir}/htmldoc/fonts"
FILES_${PN} += "${datadir}/htmldoc/data"
+BBCLASSEXTEND = "native"
+
+do_compile_virtclass-native() {
+ (cd htmldoc && oe_runmake all)
+}
+do_install_virtclass-native() {
+ (cd fonts && oe_runmake 'DESTDIR=${D}' install)
+ (cd data && oe_runmake 'DESTDIR=${D}' install)
+ (cd htmldoc && oe_runmake 'DESTDIR=${D}' install)
+}
do_install() {
oe_runmake 'DESTDIR=${D}' install