aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-11 20:06:49 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-11 20:06:49 -0700
commit899c44c3fc73c3ce88e9af1ee7aff6fb3e2b1c47 (patch)
treed2ff721afff46124bd245755d858b7c1b5dde895 /recipes
parent902b98f32ffd35661e43382f47226f65528ff1b1 (diff)
downloadopenembedded-899c44c3fc73c3ce88e9af1ee7aff6fb3e2b1c47.tar.gz
start-stop-daemon: Add update-alternatives
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
index 1591b09aba..6ea0346e6e 100644
--- a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
+++ b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Debian's start-stop-daemon utility"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "PD"
-PR = "r0"
+PR = "r1"
SRC_URI = "file://start-stop-daemon.c"
@@ -18,5 +18,13 @@ do_compile() {
do_install () {
install -d ${D}/${base_sbindir}
- install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon
+ install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/start-stop-daemon start-stop-daemon start-stop-daemon.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove start-stop-daemon start-stop-daemon.${PN}
}