summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 07:26:35 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 07:26:35 +0100
commit1b045e71ce7c3b7ed6c68ae1d60e974edbe38efc (patch)
tree7e68c7f42d115bfc1da295badb83d530b695d6e3 /recipes
parente2e4fe0cfbe97b662189fb820b02cf0511678713 (diff)
downloadopenembedded-1b045e71ce7c3b7ed6c68ae1d60e974edbe38efc.tar.gz
python-pyqt: only apply patches for qreal on arm/mips machines
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python-pyqt_4.4.3.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes/python/python-pyqt_4.4.3.bb b/recipes/python/python-pyqt_4.4.3.bb
index 08a8fc6683..8033bc5e7d 100644
--- a/recipes/python/python-pyqt_4.4.3.bb
+++ b/recipes/python/python-pyqt_4.4.3.bb
@@ -7,7 +7,7 @@ LICENSE = "GPL"
DEPENDS = "sip-native python-sip"
RDEPENDS = "python-core"
SRCNAME = "pyqt"
-PR = "ml4"
+PR = "ml5"
PYQT_OE_VERSION = "Qt_4_4_1"
@@ -16,13 +16,21 @@ SRC_URI = "\
file://cross-compile.patch;patch=1 \
file://01_configure.dpatch;patch=1 \
file://02_htmllinks.dpatch;patch=1 \
- file://03_qreal.dpatch;patch=1 \
- file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1 \
\
file://assistantclient-fix.patch;patch=1 \
"
S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
+# arm and mips machines need some extra patches
+
+SRC_URI_append_arm = "\
+ file://03_qreal.dpatch;patch=1 \
+ file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+
+SRC_URI_append_mipsel = "\
+ file://03_qreal.dpatch;patch=1 \
+ file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+
inherit qt4x11 sip distutils-base
PARALLEL_MAKE = ""