summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-04-25 18:38:21 +0100
committerKoen Kooi <koen@openembedded.org>2010-08-18 12:10:12 +0200
commit1b5b4fd868032e91439cc8baef00d41dabbba572 (patch)
tree6b91ddfb848a8b68299f0b4f06f390d4f0705e17 /recipes
parent89a9abb4c66c7a70bdb313008fc2461ac9485cbd (diff)
downloadopenembedded-1b5b4fd868032e91439cc8baef00d41dabbba572.tar.gz
u-boot_git.bb : newer gcc dont allow weak inlines
Diffstat (limited to 'recipes')
-rw-r--r--recipes/u-boot/u-boot-git/omapzoom2/inline-fix.patch15
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/omapzoom2/inline-fix.patch b/recipes/u-boot/u-boot-git/omapzoom2/inline-fix.patch
new file mode 100644
index 0000000000..7bcfa8aec3
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/omapzoom2/inline-fix.patch
@@ -0,0 +1,15 @@
+Index: git/common/cmd_voltage.c
+===================================================================
+--- git.orig/common/cmd_voltage.c
++++ git/common/cmd_voltage.c
+@@ -23,8 +23,8 @@
+ #if defined(CONFIG_CMD_VOLTAGE)
+
+ /* To use, the board should define its own voltag_info function */
+-void inline __voltage_info (void) {}
+-void inline voltage_info (void) __attribute__((weak, alias("__voltage_info")));
++void __voltage_info (void) {}
++void voltage_info (void) __attribute__((weak, alias("__voltage_info")));
+
+ int do_voltage (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
+ {
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 5a469616dd..f82f570b92 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -178,7 +178,8 @@ SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
SRC_URI_omapzoom2 = "git://dev.omapzoom.org/pub/scm/bootloader/u-boot.git;branch=master;protocol=git \
- file://0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch"
+ file://0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch \
+ file://inline-fix.patch"
SRCREV_omapzoom2 = "78e778e0ea884306841c6499851a1e35177d81d0"
PV_omapzoom2 = "1.1.4+${PR}+gitr${SRCREV}"
PE_omapzoom2 = "1"